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DIE PHILOSOPHIE VON ALTIUM DESIGNER
Das Kernprinzip von Altium Designer ist ein einheitliches Konzept für PCB-Design. In der Umsetzung dieses Ansatzes werden 

Sie feststellen, dass unser Werkzeug sich von vielen der derzeit verfügbaren, herkömmlichen Alternativen unterscheidet. 

Bei diesen finden Sie noch eine Reihe von separaten Elementen vor, die in unserem Workflow für eine erfolgreiche PCB-

Entwicklung zusammengeführt sind.

Als bestehender PADS® Anwender verwenden Sie für jede Phase Ihres Design-Prozesses mehrere Schnittstellen und 

Werkzeuge. Da sich jedes dieser Werkzeuge durch eine spezielle Aufgabe auszeichnet und auch anders bedient wird, müssen 

Sie verschiedene Arbeitsabläufe und Methoden verwalten. Während unserer eigenen Zeit als PCB-Designer haben wir uns 

immer wieder die Frage gestellt: ist dieser Ansatz wirklich effektiv?

Als wir Altium Designer geschaffen haben, wollten wir dem Entwickler das Erlebnis präsentieren, die vollständige und effiziente 

Kontrolle über alle Arbeitsabläufe im gesamten Design-Prozess zu bekommen. Um dieses Ziel zu erreichen, mussten auch 

wir uns überlegen, welche einzelnen Aufgaben zu einem kompletten PCB-Design-Erlebnis für den Entwickler dazugehören. Im 

Rahmen unseres Ansatzes haben wir die folgenden Prozesse in einer gemeinsamen Oberfläche verbunden:

�� Schaltplanerstellung

�� Leiterplatten-Layout

�� Design-Datenverwaltung

�� Regeln und Vorgaben

�� Stücklisten

�� Integration der Lieferkette

�� Änderungsverwaltung

�� MCAD-Kollaboration

�� Fertigungsdokumentation

Durch die Verknüpfung dieser Elemente in einer einzigen allumfassenden Oberfläche wird das Arbeiten und das Hin-und 

Herschalten zwischen den Aufgaben so einfach wie das Auswählen einer Datei. Den Rest übernimmt das Werkzeug und gibt 

Ihnen alles an die Hand, was Sie für die jeweilige Aufgabe benötigen.

Unser einheitlicher Ansatz für das PCB-Design ist seit mehr als 30 Jahren durch Forschung und Entwicklung kontinuierlich 

gewachsen. Wie wir finden, ist dies nach wie vor der effizienteste Weg Elektronik zu entwickeln. Diese Philosophie trifft nicht nur 

für den einzelnen Entwickler zu, sondern für das gesamte Design-Team. Mehrere Entwickler können verschiedene Aufgaben 

am gleichen Projekt und in der gleichen Arbeitsumgebung erledigen. Ein Datenaustausch zwischen unterschiedlichen Design-

Umgebungen gehört der Vergangenheit an.

Genießen Sie die Reise in die Welt von Altium Designer.

David Cousineau,

Senior Field Applications Engineer & das Altium Designer Team

http://www.altium.com
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VORBEREITUNG DER PADS® DATEIEN

INSTALLATION DES IMPORTERS

Bevor man die PADS® Daten importieren kann, muss sichergestellt sein, dass der PADS® Importer installiert sind. Dies kann 

direkt in Altium Designer mit den folgenden Schritten durchgeführt werden:

1. Altium Designer öffnen.

2. File » Import Wizard auswählen.

3. Next anwählen.

Die nächste Seite, “Select Type of Files to Import” listet die installierten Importer.

Auswahl des Dateityps im Altium Designer Import Wizard

Während der Installation von Altium Designer kann ausgewählt werden, welche Im- und Exporter installiert werden sollen. 

Der PADS® Importer ist normalerweise Bestandteil einer Standardinstallation von Altium Designer und muss nicht manuell 

ausgewählt werden

Wenn die Einträge “PADS ASCII Design and Libraries Files” in der oben gezeigten Liste fehlen sollten, dann wird er folgendermaßen 

hinzugefügt:

1.	 Get More Importers am unteren linken Rand der Import Wizard Dialog-Box auswählen. Dies öffnet den Extensions & 
Updates Tab innerhalb der Altium Designer Umgebung.

http://www.altium.com
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Altium Designer Extensions & Updates Bereich

2.	 Configure auf der rechten Seite auswählen und zum Bereich Importer/Exporter runterscrollen.

3.	 Den Eintrag PADS® aktivieren.

4.	 Ganz nach oben zurückscrollen und Apply auswählen. Altium Designer muss neu gestartet werden, um die Installation 

abzuschließen.

Aktivierung des PADS® Importers im Bereich Altium Designer Extensions & Updates

Altium Designer Extensions & Updates Bereich

http://www.altium.com
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5.	 File » Import Wizard auswählen. Der PADS® Importer sollte nun in der Liste erscheinen.

Ist der Importer installiert und gelistet, kann mit der Vorbereitung der PADS® Dateien begonnen werden

UNTERSTÜTZTE PADS® VERSIONEN & DATEIFORMATE

Der PADS® Import Wizard für Altium Designer unterstützt eine Vielzahl von Dateiversionen, wie unten aufgeführt. Es wird 

empfohlen, die neueste PADS® Dateiversion zu verwenden.

�� PADS® Logic/PowerLogic – V5.x, V2005.x, V9.x bis einschließlich V9.5

�� PADS® Layout/PowerPCB – V5.0, V2005.x, V2007.x, V9.x bis einschließlich V9.5

Folgende Punkte sind zu beachten, wenn der Import Wizard genutzt wird:

�� Der Import Wizard übersetzt Schaltpläne, PCBs und Bibliotheksdateien.

�� Der Wizard nutzt ausschließlich ASCII-Textdateien für die Migration.

�� PADS® Binärdaten (beispielsweise mit der Endung `*.pcb‘) werden nicht unterstützt.

Wenn keine ASCII-Daten zur Verfügung stehen sollten, ist möglicherweise eine gültige Lizenz für PADS® erforderlich, um sie zu 

erstellen. Im Folgenden werden die Erzeugung der ASCII-Daten des jeweiligen Editors beschrieben.

ERSTELLUNG DER ASCII-DATEN

PADS® LOGIC

Schaltpläne müssen im `*.txt` ASCII-Format exportiert werden. Dies kann mit den folgenden Schritten durchgeführt werden.

1.	 Den Schaltplaneditor in PADS® Logic öffnen.

2.	 File » Export auswählen.

3.	 Gegebenenfalls den Dateinamen und/oder den Ordnerpfad ändern und Save drücken.  

4.	 Im nächsten Dialog Select All auswählen und alle Schaltpläne für den Export einfügen. 

5.	 In der Dropdown-Liste die gewünschte Version auswählen.

6.	 OK zum Starten des Exports.

ASCII-Datei für einen Schaltplan in PADS® Logic erstellen

http://www.altium.com
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PADS® LAYOUT

PCB-Layouts müssen in ähnlicher Weise im `*.asc` ASCII-Format exportiert werden. Dies kann mit den folgenden Schritten 

durchgeführt werden.

1.	 Das PCB-Layout in PADS® Layout öffnen.

2.	 File » Export auswählen.

3.	 Gegebenenfalls den Dateinamen und/oder den Ordnerpfad ändern und Save drücken.  

4.	 Im nächsten Dialog Select All auswählen und alle PCB-Daten für den Export einfügen. 

5.	 Die gewünschte Version für die Ausgabe im Drop-Down menü auswählen.

6.	 Die Einstellung der Maßeinheit auf Basic stellen.

7.	 OK zum Starten des Exports.

ASCII-Datei für ein PCB-Design in PADS® Layout erstellen

Design Re-Use-Blöcke in PADS® Layout können nicht übersetzt werden. Wenn diese im Design vorhanden sein sollten, müssen 

sie zuerst in die Basisobjekte zerlegt werden. Dies geschieht, indem man den Block auswählt und mit der rechten Maustaste 

den Befehl Break Reuse wählt.

http://www.altium.com
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PADS® LOGIC SYMBOLBIBLIOTHEKEN

Zur Übersetzung einer PADS® Logic Bibliothek für Schaltpläne müssen zwei ASCII-basierte Dateien exportiert werden. Ein 

PADS® Symbol besteht aus zwei Teilen – den Daten aus dem CAE oder Logik-Bereich (die im Wesentlichen die grafische 

Darstellung eines Bauteils ist) und den Daten, die das Bauteil beschreiben (die eigentliche parametrische Intelligenz des 

Bauteils).

PADS® speichert die Bibliotheksstruktur mit der Dateierweiterung `*.ld9` für die grafische Darstellung und `*.pt9` für die 

Bauteilbeschreibung ab. Diese Dateien enthalten binäre Daten und müssen für eine Migration als ASCII-Daten vorliegen. Die 

entsprechenden Dateinamen sind:

�� *.ld9 (binär): *.c (ASCII)

�� *.pt9 (binär): *.p (ASCII)

Der Export der Bibliotheken kann mit den folgenden Schritten durchgeführt werden.

1.	 PADS® Logic öffnen.

2.	 Zum Öffnen des Library Managers File » Library auswählen.

ASCII-Datei für ein PCB-Design in PADS® Layout erstellen

3.	 Den Library –Filter auf eine bestimmte Bibliothek setzen (die Einstellung All Libraries kann nicht für den Export verwendet 

werden).

4.	 Den Filter auf Logic setzen und die CAE-Sektion der Bibliothek auswählen.

5.	 In der Liste `CAE Decals` die zu exportierenden graphischen Repräsentationen auswählen.

Tipp: Um die ganze Liste zu selektieren, zuerst den ersten Eintrag anklicken und dann den letzten Eintrag mit gedrückter Shift-

Taste anklicken.

http://www.altium.com


www.altium.com

MIGRATIONSLEITFADEN
WECHSEL VON MENTOR GRAPHICS PADS® ZU ALTIUM DESIGNER®

6.	 Export drücken. Dies erzeugt eine Datei  mit der Endung `*.c`.

7.	 Ohne den Library Manager zu verlassen, den Filter auf Parts setzen und den beschriebenen Vorgang wiederholen. Dies 

erzeugt eine Datei mit der Endung `*.p`.

Bemerkung: Bei der Namensvergabe der Dateien muss darauf geachtet werden, dass der Name für die Dateien `*.c` und 

`*.p` identisch sin (beispielsweise `vorschau.c` und `vorschau.p`).

Auswahl der Bauteilparameter im PADS® Logic Library Manager

Während der Übersetzung kombiniert der Import Wizard die grafischen Daten aus der *.c-Datei mit den parametrischen 

Informationen aus der *.p-Datei, um eine Altium  Designer Bibliothek für Schaltpläne mit der Dateiendung `*.SchLib` zu 

erstellen. Weitere Informationen befinden sich weiter unten im Abschnitt `Übersetzung der Bauteilbibliotheken`.

PADS® PCB-BIBLIOTHEKEN (DECALS)

Zur Übersetzung einer PADS® PCB-Bibliotheken (Decals) muss nur eine Datei exportiert werden, da eine eins-zu-eins 

Korrespondenz zwischen PADS® und Altium Designer Footprint-Bibliotheken besteht. PADS® speichert die Bibliotheksstruktur 

mit der Dateierweiterung `*.pd9` ab. Diese Datei enthält binäre Daten und muss für eine Migration im ASCII-Format vorliegen. 

Der entsprechende Dateiname ist:

�� *.pd9 (binär): *.d (ASCII)

Der Export der PCB-Bibliotheken kann mit den folgenden Schritten durchgeführt werden.

1.	 File » Export in PADS® Layout auswählen.

2.	 Den Library –Filter auf eine bestimmte Bibliothek setzen (die Einstellung All Libraries kann nicht für den Export verwendet 

werden).

3.	 Den Filter auf Decals setzen und die PCB-Decals-Sektion der Bibliothek auswählen.

http://www.altium.com
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4.	 In der Liste `PCB Decals` die zu exportierenden PCB-Bibliotheken auswählen. 

Tipp: Um die ganze Liste zu selektieren, zuerst den ersten Eintrag anklicken und dann den letzten Eintrag mit gedrückter Shift-

Taste anklicken.

5.	 OK zum Starten des Exports.

Auswahl der PCB-Bibliotheken im PADS® Logic Library Manager

Während der Übersetzung verwendet der Import Wizard ausschließlich die Dateien mit der Endung ``*.d`, um eine Altium 

Designer Footprint-Bibliothek mit der Erweiterung `*.PcbLib` zu erstellen.

Bemerkung: Die Dateien mit der Endung ‘.ln9’ der PADS®-Bibliotheksstruktur muss nicht exportiert werden, da er nicht 

direkt übersetzt werden kann. Altium Designer speichert 2D-Elemente in der Bibliotheksstruktur nicht wie PADS®, so dass 

keine äquivalente Bibliotheksdatei vorhanden ist. Wenn 2D-Elemente übersetzt werden müssen, dann müsste jedes einzelne 

Element zu einem PADS®-Schaltplan oder PCB hinzugefügt und dann übersetzt werden.

DATENINTEGRITÄT

Eine Migration verläuft nur dann reibungslos, wenn die Quelldaten in Ordnung sind. Es ist nicht ungewöhnlich, dass die 

Quelldaten in einer PADS® Datei beschädigt sind.

Wenn dies der Fall ist, heißt das nicht unweigerlich, dass die Daten in PADS® nicht verwendet werden können. Werden diese 

Daten jedoch nach ASCII exportiert, wie es für eine Migration erforderlich ist, können Anomalien bei der Formatierung der 

Informationen dazu führen, dass der Importprozess fehlschlägt. PADS® besitzt eine relativ einfache Möglichkeit Quelldaten 

auf eine Beschädigung zu überprüfen.

Die exportierten ASCII-Daten müssen dazu wieder in ein leeres Dokument im entsprechenden PADS® Editor geladen werden. 

Beim Import werden dabei die ASCII-Informationen auf Konsistenz überprüft und wenn etwas `Ungewöhnliches` entdeckt 

wird, überspringt der Importer das Element und protokolliert einen Fehler.

http://www.altium.com


www.altium.com

MIGRATIONSLEITFADEN
WECHSEL VON MENTOR GRAPHICS PADS® ZU ALTIUM DESIGNER®

Dieser Vorgang ist unter PADS® Anwendern als “ASCII-ing in” bekannt. Nach dem Erstellen der ‘*.asc’  Datei aus einem PADS® 

Layout Design wird mit File » New eine neue, leere Design-Datei erzeugt. Danach wird mit File » Import die vorher erzeugte 

‘*.asc’  Datei eingelesen.

Wenn in der ASCII-Datei keine Fehler sind, sollte die Leiterplatte so erscheinen, wie sie es ursprünglich ausgesehen hat. Wenn es 

allerdings Probleme geben sollte, dann werden diese im Ausgabefenster am unteren Rand der PADS®-Umgebung dargestellt 

und ein Fehlerprotokoll für weitere Untersuchungen geschrieben. Erst wenn alle PADS®-bezogenen Probleme behoben sind, 

kann eine neue ASCII-Datei für die Übersetzung mit dem Import Wizard erstellt werden.

ÜBERSETZUNG DER SCHALTPLÄNE

SCHALTPLAN IMPORT-PROZESS

Der eigentliche Prozess des Imports eines PADS® Logic Schaltplans ist einfach und unkompliziert. Gehen Sie nach den 

folgenden Schritten vor:

1.	 Import Wizard über File » Import Wizard in Altium Designer aufrufen.

2.	 Im Begrüßungsbildschirm auf Next klicken.

3.	 Unter File Types den Eintrag „PADS® ASCII Design and Library Files” auswählen und anschließend auf Next klicken.

4.	 Add zum Laden einer PADS® Design-Datei wählen (gemäß der Voreinstellung in diesem Bildschirm wird nach PADS® 

Layout-Dateien mit der Namenserweiterung ‚*.asc’ gesucht).

5.	 Mit dem Dropdown.Menü unten rechts auf „PADS® Logic Files (‚*.txt’)“ ändern und danach die exportierte PADS® Logic 

Datei suchen.

Laden von PADS®-Designdateien mit dem Import Wizard von Altium Designer

In diesem Dialog können mehrere Dateien für die Umwandlung ausgewählt werden. Befinden sich diese Dateien in 

verschiedenen Ordnern, wird erneut der Add-Button geklickt und ein anderer Speicherort ausgewählt, um weitere Dateien 

hinzuzufügen.

Hinweis: Es ist auch möglich, PADS® Logic-Dateien und PADS® Layout-Dateien in einer Sitzung zu konvertieren. Hierfür 

lediglich nach dem Anklicken von Add den Dateityp für Layout-Dateien auf „PADS® Design Files (*.asc)” ändern.
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6.	 Auf Next klicken, um im Import Wizard fortzufahren.

7.	 Es wird empfohlen, im Reporting Options-Bildschirm den Eintrag ‚Do not translate hidden net names’ zu aktivieren.

Hinweis: Jedes Softwaresystem für die Erfassung von Schaltplänen bedient sich eines eigenen Verfahrens zur Benennung von 

Netzen, die nicht vom Anwender benannt wurden (z. B. Netze, die keinen bestimmten Namen wie CLK oder GND bekommen 

haben). PADS® Logic vergibt hier Namen, die mit ‚$$$‘ beginnen und anschließend eine zufällig vergebene Zahlenfolge 

enthalten (z. B. $$$16581). 

Altium Designer geht bei der automatischen Benennung anders vor (auf den Präfix ‚Net‘ folgt die Pin-Nummer eines verbundenen 

Bauelements – z. B. NetC1_1). Es ist besser, Altium Designer die automatische Benennung dieser nicht bezeichneten Netze zu 

erlauben. Der entscheidendste Nachteil ist, dass diese ‚$$$‘-Netzbezeichnungen bei der Übertragung nach Altium Designer im 

Schaltplan zu sehen wären, was visuell verwirrend sein und sogar Verbindungsfehler hervorrufen kann.

Konfigurieren der Report-Optionen im PADS® Import Wizard

8.	 Auf Next klicken, um zur Review-Seite zu gelangen. Dort gibt es eine Zusammenfassung dessen, was umgewandelt wird 

und wo die Dateien abgespeichert werden.

9.	 Als ‚Project Output Directory’ ist standardmäßig der Speicherort der ausgewählten Datei(en) angegeben. Es ist deshalb 

nicht nötig, eigens einen Ordner für die umgewandelten Dateien anzulegen.

Hinweis: Die Ergebnisse der Umwandlung (also die erstellten Altium Designer Dateien) werden in einem Unterordner des 

Output Directory abgelegt, sodass das Einrichten eines eigenen Ordners für die umgewandelten Daten nicht erforderlich ist.

10.	 Auf Next klicken, um den Import zu starten. Wie viel Zeit für diesen Vorgang benötigt wird, hängt von Anzahl und Größe 

der Designs ab – hier sind Zeitspannen zwischen wenigen Sekunden für kleine Designs und bis zu mehreren Minuten für 

sehr große Designs möglich. Sobald der Vorgang abgeschlossen ist, erscheint die ‚Complete‘-Meldung, die mit einem Klick 

auf Finish geschlossen wird, um die umgewandelten Schaltpläne anzuschauen.
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SCHALTPLAN AUFRÄUMEN

Es wird immer ein wenig zu bereinigen geben. Ursache hierfür sind meist Inkompatibilitäten zwischen den Datenstrukturen 

der beiden CAD-Systeme oder schlicht unterschiedliche Implementierungen bestimmter Funktionalitäten oder Objekttypen.

In diesem Abschnitt geht es um jene Bereiche der konvertierten Schaltpläne, die in der Regel genauer untersucht werden 

sollten. Für diesen und die weiteren Abschnitte zum Thema Bereinigung wird vorausgesetzt, dass der Anwender wenigstens in 

Grundzügen mit der Bedienung von Altium Designer vertraut ist. Erlernen lassen sich die Grundlagen von Altium Designer mit 

der Dokumentation Getting Started with Altium Designer.

Steckverbinder

Zu den wichtigsten Unterschieden zwischen PADS® Logic und Altium Designer gehört die Unterstützung für Steckverbinder. 

In PADS® Logic gibt es eine besondere Art von Steckverbindern, die es ermöglicht, die Pins eines Steckverbinders einzeln zu 

platzieren und zu verschieben.

Altium Designer unterstützt dies nicht, sondern behandelt Steckverbinder so wie alle anderen Komponenten, bei denen 

sämtliche Pins zu einem Block zusammengefasst sind. Es folgt ein Beispiel für einen Logic-Schaltplan, in dem die Pins von 

Steckverbinder P1 einzeln platziert wurden.

Beispiel für einen Steckverbinder in PADS® Logic

Im Vergleich dazu sind bei einem typischen Steckverbinder in Altium Designer alle Pins gemeinsam in einem Symbol 

zusammengefasst, wie die folgende Abbildung zeigt:

Beispiel für einen Steckverbinder in PADS® Logic

http://www.altium.com
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Wegen dieser Inkompatibilität müssen alle Steckverbinder, die in PADS® Logic auf diese Weise erstellt wurden, durch einen 

Steckverbinder in der in Altium Designer üblichen Block-Bauweise ersetzt werden. Dies kann vor oder nach der Umsetzung 

geschehen und kann einige tiefgreifende Änderungen im Layout des Schaltplans mit sich bringen.

Entfernen umgewandelter Steckverbinder in Altium Designer

Zum schnellen Entfernen konvertierter Steckverbinder in Altium Designer eignet sich die Funktion ‚Find Similar Objects‘, die 

wie folgt bedient wird:

1.	 Zunächst wird nach einem der Steckverbinder gesucht. Da dieser Objekttyp nicht unterstützt wird, wurde keine grafische 

Umwandlung vorgenommen.

2.	 Den Punkt auswählen, an dem der Steckverbinder-Pin sein sollte. Daraufhin wird das ‚Phantom‘-Bauteil wie unten zu sehen 

ausgewählt und angezeigt:

Auswahl von Steckverbinder-Pins in Altium Designer

3.	 Einen Rechtsklick in der Auswahlbox machen und im Dropdown-Menü den Menüpunkt Find Similar Objects auswählen.

4.	 Nach unten zum Feld ‚Symbol Reference‘ scrollen und den Dropdown-Dialog von Any auf Same ändern.

5.	 Das  Häkchen bei Select Matching ganz unten muss gesetzt sein. Weiter gehts mit Next.

6.	 Sind alle Steckverbinder-Pins ausgewählt, werden sie durch einen einfachen Druck auf die Entf-Taste alle von dieser Seite 

gelöscht. Den Vorgang für jede Schaltplanseite wiederholen.

Anwendung der Funktion Find Similar Objects in Altium Designer
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Weitere Informationen über die Funktion Find Similar Objects finden Sie in den folgenden Dokumentations-Artikeln zu Altium 

Designer:

�� Editing multiple objects in Altium Designer

�� Finding similar objects in Altium Designer

Zeichnungsrahmen und Vorlagen

Während Altium Designer wiederverwendbare Vorlagen für Schaltpläne unterstützt, sind die Zeichnungsrahmen in PADS® 

Logic kaum mehr als eine Kombination aus Linien, Texten und Grafiken und dementsprechend nicht von anderen 2D-Objekten 

zu unterscheiden. Diese Daten werden deshalb in ihrer Rohform als Linien bzw. Text übernommen, während eingebettete 

Grafiken (z. B. Logos) nicht umgewandelt werden.

Altium Designer zeigt automatisch seinen eigenen Zeichnungsrahmen an. Es kann deshalb so aussehen, als seien Informationen 

doppelt vorhanden. Dem Anwender bleibt überlassen, ob er den umgewandelten Rand übernehmen oder ihn durch ein 

Template von Altium Designer ersetzen möchte. Die Anzeige des Zeichnungsrahmens lässt sich mit den folgenden Schritten 

schnell deaktivieren:

1.	 Design » Document Options auswählen.

2.	 Im Reiter Sheet Options die Häkchen bei Title Block und Show Reference Zones entfernen, wie unten gezeigt.

3.	 Zum Entfernen des importierten Rahmens lassen sich mehrere Methoden nutzen, um die betreffenden Daten auszuwählen 

und zu löschen. Beispiele sind ‚Find Similar Objects’ oder die Befehle im Menü Edit » Select (hier speziell Select Outside 

Area).

Konfigurieren der Dokument-Optionen in Altium Designer

Net Labels

Ein weiterer gravierender Unterschied zwischen Altium Designer und PADS® Logic betrifft die Benennung von Netzen. Bei 

PADS® Logic kann in ein Signal oder eine Verbindung eine Eigenschaft eingebettet werden, die den Namen des Netzes angibt 

(z. B. CLK). Dieser Name kann dann entweder im Schaltplan angezeigt oder verborgen werden.
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Altium Designer geht einen anderen Weg und platziert einen besonderen String-Typ namens ‚Net Label‘ räumlich auf der 

Verbindung. Wenn in PADS® Logic ein Netzname existiert und nach Altium Designer übernommen wird, wird das betreffende 

Net Label in der Mitte der jeweiligen Leitung platziert.

Eine zwar sehr seltene, aber durchaus mögliche Situation ist, dass die Mitte eines Leitungssegments genau auf den Schnittpunkt 

mit einer anderen Leitung fällt. In diesem Fall wird das Net Label genau auf dem Schnittpunkt beider Leitungen platziert und 

benennt damit effektiv beide Leitungen.

Net Label am Schnittpunkt zweier Leitungen

In diesem Fall ist das Label BRD_ID0 mit der vertikalen Leitung verbunden, aber auch mit der horizontalen Leitung, die zum Port 

STAND_AL_IND führt. Das Netz STAND_AL_IND wird dadurch in BRD_ID0 umbenannt, was natürlich nicht gewollt ist.

Eine Möglichkeit, ein solches Problem aufzudecken, ist die visuelle Inspektion des Designs. Eine bessere Möglichkeit setzt 

voraus, dass es ein zugehöriges PCB-Design gibt, das ebenfalls von PADS® Logic nach Altium Designer umgewandelt wurde. 

Sind Schaltplan und PCB synchronisiert, deckt eine ECO auf, wenn das System versucht, ein Netz umzubenennen. Dies ist ein 

gutes Indiz dafür, dass es im Schaltplan ein im ursprünglichen Design nicht beabsichtigtes Konnektivitätsproblem gibt.

Mit einer ECO lässt sich ein Schaltplan auf Konnektivitätsprobleme überprüfen
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Im obigen Beispiel handelt es sich bei den vier Netzen, deren Namen mit $$$ beginnen, um die systemseitig zugewiesenen 

Namen, die – so wie es sein soll – aus dem PADS® Logic-Format in das Format von Altium Designer umgewandelt wurden. 

Nicht gewollt war dagegen die Umbenennung des Netzes 24MHZ in D0. Hier sind deshalb weitere Untersuchungen nötig.

Widersprüchliche Net Labels in Altium Designer

Nach einem Cross Probing zum Schaltplan stellen wir fest, dass das Net Label 24MHZ sowohl an der eigenen Leitung als auch 

an der mit D0 bezeichneten Leitung angebracht wurde. Der daraus resultierende Konflikt muss behoben werden, indem das 

Net Label 24MHZ von der Leitung D0 entfernt wird.

Manuell platzierte Parameter

Sichtbare Komponenten-Parameter in Altium Designer werden in der Regel als ‚autopositioned’ definiert. Das bedeutet, dass 

das System den Parameter – einschließlich eines Referenz-Bezeichners – an einem vorgegebenen Ort neben dem Symbol 

platziert. Hilfreich ist dies beim Drehen von Komponenten, denn das System sorgt stets dafür, dass die Parameter übersichtlich 

und gut lesbar angeordnet sind.

Im Bemühen, den Quell-Schaltplan aus PADS® Logic möglichst originalgetreu zu importieren, ist die automatische Positionierung 

bei importierten Parameter deaktiviert. Die Kurzbezeichnungen für Bauteile und Parameter werden stattdessen so nah wie 

möglich an ihrer ursprünglichen Position platziert und jetzt als ‚manuelle Parameter‘ bezeichnet.

Wegen der Unterschiede in der standardmäßigen Schriftart und -größe ist eine genaue Übereinstimmung nicht immer 

erreichbar, sodass der Anwender möglicherweise den Wunsch hat, die Textposition des Parameters zu ändern.

Manuell positionierte Parameter sind mit einem kleinen Punkt markiert, wie die folgende Abbildung zeigt:

Widersprüchliche Net Labels in Altium Designer
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Man kann auf dreierlei Weise mit solchen manuellen Parametern umgehen:

�� Das Design unverändert.lassen.

�� Die Parameter lassen wo sie sind, aber die Punkte entfernen. Hierzu Tools » Schematic Preferences und anschließend 

die Gruppe Graphical Editing wählen und anschließend die Option Mark Manual Parameters deaktivieren.

�� Erneut die die Einstellung ‚Autoposition’ im Dialogfeld Parameter Properties aktivieren, wie nachfolgend gezeigt.Hierfür 

können eine Kombination aus ‚Find Similar Objects’ und dem ‚SCH Inspector’-Fenster genutzt werden.

Editieren von Parameter-Eigenschaften in Altium Designer

Da das automatische Positionieren von Parametern nur beim Platzieren eines Bauelements oder beim Rotieren erfolgt, werden 

die Auswirkungen erst dann sichtbar, wenn Bauelemente gedreht werden. 

Alle Bauelemente können an ihrem Ort gedreht werden:

1.	 Strg+A drücken, um alles auf der Schaltplanseite zu markieren.

2.	 Mit der Leertaste kann nun alles um 90° gedreht werden.

3.	 Durch Drücken von Shift+Leertaste wird alles wieder in die ursprüngliche Position zurückgedreht.

Sämtliche Parameter und Bezeichner werden daraufhin automatisch positioniert.

Unterschiede in der Konnektivität

Viele weitere subtile Unterschiede zwischen PADS® Logic und Altium Designer gibt es hinsichtlich der zulässigen Konnektivitäts-

Strukturen. Altium Designer unterstützt eine echte Hierarchie, in der Verbindungen sowohl horizontal als auch vertikal von 

einer Schaltplanseite zur anderen wechseln können. PADS® Logic dagegen unterstützt keine dieser komplexen Strukturen bei 

Schaltplänen.

Zutage treten können Konnektivitätsprobleme nach dem Durchlaufen des Project Compile-Prozesses (Project » Compile PCB 
Project). Das Messages-Fenster enthält entsprechende Fehler und Warnungen, die auf solche Unstimmigkeiten hinsichtlich 

der Hierarchie und der Konnektivität hinweisen. Der Fehler ‚Duplicate net names‘ etwa verweist auf unrichtige Verbindungen 

zwischen Schaltplanseiten.
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Es können hier nicht alle denkbaren Situationen behandelt werden. Besser ist es, wenn man sich in der technischen 

Dokumentation mit dem Thema Connectivity and Multi-Sheet Design vertraut macht.

Invertierte Signale

PADS® Logic und Altium Designer nutzen geringfügig unterschiedliche Methoden zur Kennzeichnung eines invertierten 

Signals. In PADS® Logic zeigt ein Backslash (\) an, dass alle folgenden Zeichen mit einem Querstrich darüber gemeint sind. 

Ein invertiertes Signal namens INIT würde folglich mit dem Namen \INIT bezeichnet werden und somit im Schaltplan wie folgt 

erscheinen:

Kennzeichnung invertierter Signale in PADS® Logic

Altium Designer unterstützt gleich zwei Methoden zum Kennzeichnen invertierter oder negierter Signale. Wenn das Zeichen 

‚\‘ als erstes Zeichen in einem Net Label erscheint und für Schaltpläne die Einstellung Single ‘ \ ’ Negation aktiviert (Tools » 
Schematic Preferences » Schematic » Graphical Editing), so erscheint das Netz \INIT im Schaltplan wie folgt:

Invertierte Signale in Altium Designer (Möglichkeit 1)

Die andere in Altium Designer unterstützte Methode besteht darin, das ‚\‘-Zeichen nach dem zu invertierenden Zeichen zu 

setzen. Der Hauptunterschied hierbei ist, dass sich jedes Zeichen einzeln invertieren lässt. Das invertierte INIT müsste also 

I\N\I\T\ geschrieben werden. Auf diese Weise sind auch gemischte Bezeichnungen wie HIGHL\O\W\ möglich.

Invertierte Signale in Altium Designer (Möglichkeit 2)

Die gleiche Netzbezeichnung würde in PADS® Logic HIGH\LOW geschrieben (alles nach dem ‚\‘-Zeichen wird invertiert). 

Da die Negierung mit einem ‚\‘ in Altium Designer das Ändern einer Voreinstellung erfordert (und verschiedene Benutzer 

möglicherweise mit unterschiedlichen Voreinstellungen arbeiten), ist es in der Regel sicherer, den Backslash jeweils nach den 

zu invertierenden Zeichen zu setzen.

Es ist empfehlenswert, die Schaltpläne nach invertierten Signalen abzusuchen und die betreffenden Net Labels von der PADS®-

Bezeichnungsweise mit einem Backslash auf die in Altium Designer übliche Bezeichnungsweise mit mehreren Backslash-

Zeichen zu ändern.
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Die betreffenden Netze lassen sich auf verschiedene Weise lokalisieren. Eine Möglichkeit ist die Verwendung von Edit » Find 
Text. Alternativ wird das Projekt zunächst kompiliert, um anschließend in das Navigator-Fenster (View » Workspace Panels 
» Design Compiler » Navigator) zu wechseln. Werden die Netze/Busse nach Namen sortiert, so erscheinen die mit einem ‚\’ 

beginnenden Namen ganz oben oder ganz unten in der Liste. Die Änderungen selbst müssen manuell oder mithilfe von Edit 
» Replace Text vorgenommen werden.

ÜBERSETZUNG DES PCBS

PCB IMPORT-PROZESS

Das Umwandeln eines PADS® Layouts beginnt auf die gleiche Weise wie eine PADS® Logic-Umwandlung. Die Vorgehensweise 

ist folgendermaßen:

1.	 File » Import Wizard auswählen.

2.	 Auf dem Begrüßungsbildschirm auf Next klicken, dann ‚PADS® ASCII Design and Library Files‘ auswählen. Weiter geht es 

mit Next.

3.	 Mit Add werden eine oder mehrere Design-Dateien geladen. Voreingestellt sind Dateien mit der Endung ‚*.asc’.

Laden von PADS® Designdateien in den Altium Designer Import Wizard

Warnhinweis: Nicht vergessen, dass PADS® mit zwei Dateiformaten arbeitet, die die Namenserweiterung ‚*.asc‘ tragen. Bei 

einem handelt es sich um den zuvor beschriebenen Export der PCB-Datei, bei der anderen dagegen um die Netzliste, also 

die aus dem Schaltplan erzeugte und zum Befüllen des PCB verwendete Datei. Dieses Dateiformat kann hier nicht verwendet 

werden. Beide Dateien sind textbasiert und lassen sich mit einem Texteditor öffnen. Die (korrekte) ASCII-Datei für den PCB-

Export beginnt etwa wie folgt:

!PADS®-POWERPCB-V9.5-BASIC! DESIGN DATABASE ASCII FILE 1.0
*PCB*        GENERAL PARAMETERS OF THE PCB DESIGN

UNITS        0              2=Inches 1=Metric 0=Mils
USERGRID     317373 317373  Space between USER grid points
MAXIMUMLAYER 4              Maximum routing layer
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Die (nicht benötigte) Netzlisten-Datei sieht dagegen so aus:

!PADS®-POWERPCB-V9.0-MILS! NETLIST FILE FROM PADS® LOGIC V9.5
*REMARK* PREVIEW.SCH -- Thu Oct 15 09:06:19 2015
*REMARK*  
*PART*       ITEMS
U1      87C256@SO28
U2      87C256@SO28

4.	 Auf Next klicken, um im Assistenten fortzufahren. Werden Bibliotheksdateien umgewandelt, können diese auf dem 

nächsten Bildschirm ausgewählt werden.

5.	 Der Bildschirm Reporting Options kann unverändert gelassen werden (unter der Annahme, dass keine Schaltpläne 

konvertiert werden).

6.	 Der Bildschirm Default Options kann ein paar Anpassungen erfordern, bevor es wie unten erläutert weitergeht.

Laden von PADS® Designdateien in den Altium Designer Import Wizard

�� Design Rules: Dieser Abschnitt ist selbsterklärend. Es geht darum, ob die Abstands-, Routing- und High Speed-Regeln 

importiert werden sollen oder nicht.

�� Keep-Out Options: Werden diese Optionen nicht aktiviert (Häkchen nicht gesetzt), werden alle Plazierungs-, Trace/Kupfer- 

und Kupferflächen-Keepouts in PADS® in Sperrflächen in Altium Designer umgewandelt. Zwischen den beiden Werkzeugen 

gibt es hier einen wesentlichen Unterschied, denn die Keepouts von PADS® können dahingehend konfiguriert werden, für 

welche Objekttypen sie gesperrt sind. Bei Altium Designer sind die Keepouts dagegen global, und deshalb werden hier alle 

elektrischen Projekte (Leiterbahnen, Vias, Flächen usw.) daraufhin überprüft, ob sie gegen eine Regel verstoßen.

Hinweise:

Placement: In Altium Designer nutzt die Entsprechung zu einer Plazierung-Sperrfläche einen Raum. Deshalb ist es ratsam, die 

Option Import Placement Keep-Outs As Rooms zu aktivieren.

Trace & Copper: Die Keepout-Funktion von Altium Designer arbeitet größtenteils wie PADS® Trace & Copper (nicht Copper 

Pour). Diese Option kann somit in der Regel deaktiviert bleiben, damit ein Keepout ein Keepout bleibt.
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Copper Pour & Plane: Die Kupferflächen-Cutouts in Altium Designer entsprechen denen in PADS®. Es ist deshalb am sichersten, 

diese Option stets aktiviert zu lassen. 

�� Internal Plane Options: Für Lagen, die als negative Plane-Lage konvertiert werden, muss als ‚Pullback Distance‘ der 

gewünschte Abstand zwischen dem Kupfer der Ebene und dem Leiterplattenrand eingegeben werden. In PADS® geschieht 

dies manuell, indem entweder die Board Outline-Breite auf das Doppelte des Plane Pullback-Werts eingestellt wird oder 

indem man auf der Plane-Lage eine Linie zeichnet, die dem Umriss der Leiterplatte entspricht. Mit einem Eintrag im Layer 

Stack Manager-Dialog (Design » Layer Stack Manager) stellt Altium Designer diese Pullback-Distanz automatisch ein. 

Zum richtigen Einstellen dieses Werts müssen Sie als Benutzer wissen, wie das Design erstellt wurde.

�� Options: Die wichtige Option in dieser Liste ist ‚Generate Teardrops‘. Ist diese Option aktiviert, wird das Design automatisch 

mit Teardrops versehen – unabhängig davon, ob diese im ursprünglichen Design vorhanden waren oder nicht. Es wird 

dringend empfohlen, diese Option zu deaktivieren. Wenn das ursprüngliche PADS®-Design Teardrops enthält, werden 

diese entfernt, da ihre Struktur von der Art und Weise abweicht, wie Teardrops in Altium Designer erzeugt werden.

Zuordnung der Lagen

Beim weiteren Fortgang des Imports Ihrer PCBs müssen die Zuordnung der Lagen konfiguriert werden und den Importprozess 

mit den nachfolgend beschriebenen Schritten abgeschlossen werden:

7.	 Der Bildschirm Default Options kann ein paar Anpassungen erfordern, bevor es wie unten erläutert weitergeht.

Dabei wird beispielsweise versucht, die Lagen für Siebdruck in PADS auf Lagen für Siebdruck in Altium Designer abzubilden. Die 

Zuordnung der Lagen kann auf Wunsch manuell angepasst werden. Außerdem können PADS-Lagen auf ‚Not Imported‘ gesetzt 

werden, wenn Informationen einer bestimmten Lage verworfen werden können. Es ist nicht notwendig, alle PADS-Lagen auf 

eine entsprechende Altium-Lage abzubilden.

Was die Innenlagen betrifft, werden die inneren Signal- (Routing-)Lagen bei PADS® auf Signallagen von Altium Designer 

abgebildet (z. B. ‚Mid Layer 1‘). PADS® CAM Plane-Lagen werden als Altium Designer Plane-Lagen abgebildet (z. B. ‚Internal 

Plane 1‘), bei denen es sich um Negativ-Planes handelt. Als Split/Mixed-Lagen definierte Innenlagen von PADS® werden 

in Altium Designer als Signallagen gehandhabt, sofern irgendwelche Leiterbahnen oder andere als Positivbild dargestellte 

elektrische Daten vorliegen.

Wenn eine Split/Mixed-Lage nur Kupferflächen enthält, wird sie als Altium Designer Plane-Lage (negativ) initialisiert und 

als gesplitteten, eingebetteten und isolierten Plane-Flächen importiert. Diese Einstellung kann geändert werden, wenn es 

vorgezogen wird, die gesplitteten Planes als positive Lagen zu importieren.

Werden mehrere Dateien gleichzeitig konvertiert, gibt es für jede Datei eigene Einstellungen für die Zuweisung von Lagen. 

Achten Sie also darauf, jeden einzelnen Lagenaufbau zu untersuchen.

8.	 Nach einem Klick auf Next erscheint die Review-Seite mit einer Zusammenfassung dessen, was migriert wird und wo die 

Dateien gespeichert werden.

9.	 Unter ‚Project Output Directory’ steht, wo die ausgewählte(n) Datei(en) gespeichert werden. Das Feld ist leer, wenn mehrere 

Zielordner gewählt wurden.

10.	Mit einem Klick auf Next beginnt jetzt der Übersetzungsprozess. Anzahl und Größe der Designs bestimmen den 

Zeitaufwand für die Umwandlung, der zwischen wenigen Sekunden bei kleinen Designs und einigen Minuten bei sehr 

großen Designs liegen kann.

11.	Nach Abschluss des Vorgangs erscheint das ‚Complete‘-Fenster, das mit Finish geschlossen werden kann, um sich die 

umgewandelte(n) PCB-Datei(en) anzusehen.
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PCB-DESIGN AUFRÄUMEN

Der Importer leistet beim Konvertieren der PCB-Dateien zwar hervorragende Arbeit, doch können auch hier Inkompatibilitäten 

zwischen beiden CAD-Systemen dafür sorgen, dass am importierten Design einige Nacharbeiten nötig sind.

Design-Regeln

Hinsichtlich der grundlegenden Abstandsregeln wenden PADS® Layout und Altium Designer ähnliche matrixbasierte Methoden 

an. So wird beispielsweise ein Wert in einer Via-to-Via-Regel von PADS® in die entsprechende Via-to-Via-Regel von Altium 

Designer umgewandelt. Das nachfolge Beispiel zeigt, wie die einzelnen Abstandswerte konvertiert werden. Im folgenden wird 

die Haupt-Matrix der Design-Regeln für Abstände betrachtet.

Abstandsregeln in PADS®

Abstandsregeln in Altium Designer
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Altium Designer unterscheidet zwischen Bögen und geraden Abschnitten einer Leiterbahn (engl. ‚Track‘). Die Abstandswerte 

für PADS®-Leiterbahnen werden in Leiterbahnen und Bögen in Altium Designer umgewandelt. Zu beachten ist ferner, dass der 

Einzelwert in PADS® für Kupfer auf Füllbereiche (Fills), Regionen und Polygone angewendet wird (Füllbereiche und Regionen in 

Altium Designer entsprechen Kupfer in PADS®, während Polygone (Kupferflächen) das Gegenstück zu Copper Pours in PADS® 

sind).

In der Matrix für die Abstände von Altium Designer fehlen die ‚Board‘-Clearance-Werte. Die Abstandseinstellung ‚Board Outline‘ 

ist eine andere Regel  (in den Design-Regeln für die Herstellung zu finden). In diesem Fall werden die Werte für die Board-

Clearance nicht an Altium Designer umgewandelt und müssen stattdessen manuell erstellt werden.

Die Drill-to-Object-Werte besitzen keine genauen Entsprechungen in Altium Designer (es kann also beispielsweise kein Check 

für den Abstand von einem Bohrungsrand zu einem SMD-Pin gemacht werden). Stattdessen bietet Altium Designer einen Hole-

to-Hole-Check als Bestandteil der Design-Regeln für die Fertigung. Der globale ‚Drill-to-Drill‘-Wert von PADS® (er lautet hier 30) 

wird dagegen als Hole-to-Hole-Regel an Altium Designer transferiert.

Tipps: 

Auch in Altium Designer lassen sich bestimmte Hole-to-Hole-Regeln definieren. Falls nötig, kann also für eine 30-mil-Bohrung 

ein anderer Abstand zu anderen Bohrungen festgelegt werden als für 20-mil-Bohrungen.

Für die Abstandsregel ‚Same Net‘ werden die Regeln für Vias in Altium Designer neu erstellt (Via-Via und Via-SMD). Allerdings 

gibt es in Altium Designer kein Objekt des Typs ‚corner‘, sodass diese Regeln nicht übertragen werden.

Bedingte Regeln in PADS® wie zum Beispiel Net Classes, Nets, Differential Pairs usw. werden alle wie erwartet transferiert.

Da es für Pin-Pairs, Pin-Pair Groups, Decals oder Components keine entsprechenden Regeltypen in Altium Designer gibt, 

erfolgt in diesen Fällen keine Umwandlung. 

Sperrflächen (Keepouts)

Wie schon im Abschnitt über den Importprozess beschrieben, besitzen Keepout-Objekte in PADS® andere Fähigkeiten als in 

Altium Designer. Während eine Sperrfläche in Altium Designer auf eine bestimmte Lage beschränkt sein und jede beliebige 

Form haben kann, wird die Sperrung auf alle elektrischen Typen angewandt, sei es ein Via, eine Leiterbahn, ein Bauteil-Pad 

usw. Im Gegensatz dazu kann ein Sperrfläche in PADS® so konfiguriert werden, dass bestimmte Objekttypen ausgeschlossen 

werden (z. B. Sperrung nur für Vias, aber nicht für Leiterbahnen).

Der Import Wizard kann mithilfe einiger Einstellmöglichkeiten sicherstellen, dass in bestimmten Szenarien die Funktionalität 

1:1 übereinstimmt (benutzen Sie ‚Import Placement Keep-Outs As Rooms’). Es muss jedoch sorgfältig vorgegangen werden, 

um zu verstehen, welche Keepout-Typen es im Quell-Design gibt, wie sie in Altium Designer funktionieren könnten und welche 

Auswirkungen sich auf die Überprüfung der Design-Regeln ergeben könnten.

Ist ein PADS®-Keepout so konfiguriert, dass die Sperrung für mehr als einen Objekttyp gilt, wird in Altium Designer nur ein 

Keepout-Objekt erstellt. Von welchem Typ das Objekt ist, hängt davon ab, welche Keepout-Optionen in PADS® gesetzt sind 

und wie die Keepout-Optionen im Import Wizard freigegeben sind.

Die Keepout-Inkompatibilitäten können sich bis in die PCB-Footprints hinein auswirken. PCB-Decals in PADS® können die 

gleichen konfigurierbaren Keepout-Objekte enthalten. Es ist beispielsweise durchaus üblich, dass Designer eine Sperrfläche 

zwischen Pads eine SMD-Kondensators anordnen, damit keine Vias zwischen den Pins platziert werden, während Leiterbahnen 

durchaus zulässig sind.

In der folgenden Abbildung enthält der Footprint in Altium Designer die Sperrfläche zwischen den Pins. Zusätzlich zur Keepout-

Prüfung für Vias wird jedoch auch bei anderen elektrischen Items (Leiterbahnen, Kupfer-Füllflächen usw.) ein Fehler gemeldet. 

Das PADS®-Keepout kann daher in ein Objekt umgewandelt werden, das unerwartete Regelverletzungen produziert.
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Footprint in PADS® mit einer Sperrfläche für Vias

Footprint in Altium Designer mit Sperrfläche

Kommt es zu dieser Situation, müssen die betreffenden Footprints in der Altium-Bibliothek geändert werden, um die Sperrfläche 

zu entfernen.

Polygone, Kupferflächen und Wärmefallen

Alle PCB-Systeme gehen unterschiedlich mit der Erzeugung von Kupferflächen und Wärmefallen um. PADS® lässt Wärmefallen 

auf unterschiedliche Weise zu, und zwar sowohl global als auch für einzelne Padstacks. Wärmefallen können sich je nach Pad-

Umriss unterscheiden (45°-Verbindung bei runden Pads gegenüber 90° bei ovalen Pads), oder werden für Decals oder sogar 

für einzelne Pins definiert. Wärmefallen für Durchkontaktierungen lassen sich für jeden Via-Stil definieren, der mit alternativen 

Anbindungsarten überschrieben werden kann. Die Einstellungen in den Design-Regeln haben möglicherweise Auswirkungen 

auf die Wärmeleitfähigkeit. Schließlich können die-Einstellungen für die Fertigungsausgaben Einfluss darauf haben, wie 

Verbindungen zu (negativen) Planes hergestellt werden.

Altium Designer geht bei der Generierung von Wärmefallen einen vollkommen anderen Weg und verwaltet diese Einstellungen 

in den Design-Regeln (Polygon Connect Style). In der Praxis erlaubt dies ein wesentlich effizienteres Erstellen von Wärmefallen, 

da sämtliche Einstellungen dafür zentral an einem Ort zusammengefasst sind.

In früheren Versionen von Altium Designer versuchte der PADS® Import Wizard, alle denkbaren, im PADS®-Design existierenden 

thermischen Verbindungs-Optionen nachzubilden. Das Resultat war eine unüberschaubare Liste mit Design-Regeln für die 

Anbindung zu Polygonen. Zwischen einer Handvoll Regeln bei einfachen Designs und buchstäblich Hunderten von Design-

Regeln bei komplexeren Designs war hier alles möglich.

Deshalb musste nach dem Konvertieren eine Bereinigung der Regeln erfolgen. Die meisten Anwender entschieden sich dafür, 

einfach alle zu entfernen und die Regeln für di Anbindung an Polygone nach der Methode von Altium Designer neu zu erstellen. 

Meist ergab dies eine kurze Liste mit Regeln, die die meisten, wenn nicht gar alle Szenarien des ursprünglichen PADS®-Designs 

abdeckten.
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Man entschied aus diesem Grund die Regeln für Wärmefallen nicht wiederherzustellen – mit der Ausnahme zweier Polygon-

Connect-Regeln, nämlich einer Default-Regel für alle Pins und Vias und einer Regel speziell für SMD-Pins. Die Default-Regel 

erzeugt eine Wärmefalle mit vier Anbindungen, bei der die Breite der Anbindung durch die in PADS® für ‚Drilled Thermals‘ im 

Dialog Options » Thermals angegebene ‘Spoke Width’ bestimmt wird.

Optionen für Wärmefallen in PADS®

Bei der SMT-Regel in Altium Designer wird die Breite der Anbindungen durch die ‘Spoke Width’ für ‚SMT Thermals‘ im Dialog 

Options » Thermals von PADS® bestimmt. Sollten irgendeine weitere Konfiguration thermischer Anbindungen erforderlich 

sein, so müssen diese Regeln in Altium Designer manuell angelegt werden. Ein gängiges Beispiel ist eine Regel, die sich speziell 

auf Vias für eine direkte Anbindung (ohne Wärmefalle) bezieht. Hierzu wird eine neue Regel erstellt und der Eintrag ‚Scope‘ auf 

‚IsVia‘ anstatt auf ‚All‘ gesetzt, während bei ‚Constraints‘ der Eintrag ‚Direct Connect‘ gewählt wird.

Weitere Informationen zum Erstellen von Design-Regeln finden Sie in der technischen Dokumentation unter Creating Design 

Rules.

Design-Regel in Altium Designer für Anbindungen in Kupferflächen
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Wärmefallen in Vollkupferlagen und Abstände

Wie schon im Abschnitt Zuordnung der Lagen über den Importprozess beschrieben, werden CAM-Planes in PADS® 

standardmäßig auf (negative) Plane-Lagen in Altium Designer abgebildet. Split/Mixed-Lagen lassen sich ebenfalls als Split 

Layers auf negative Planes in Altium Designer abbilden.

Ist dies der Fall, so werden etwaige Konnektivitäts- und Abstandsregeln ebenfalls in den Design-Regeln von Altium Designer 

festgelegt. Wegen der vielen Orte, an denen diese Regeln in PADS® festgelegt werden können, ist nicht sichergestellt, dass 

alle erfolgreich konvertiert werden (z. B. werden Padstacks, die Layer_25 für Thermal- oder Clearance-Werte nutzen, nicht 

umgewandelt). Aus diesem Grunde kann es nötig sein, spezielle Plane-Regeln zu definieren. Wenn allerdings für PADS®-

Padstacks bestimmte Thermal- oder Antipad-Werte gesetzt sind, wird in Altium Designer automatisch eine entsprechende 

Plane Connect- oder Plane Clearance-Regel erzeugt.

Konfigurieren von Padstack-Eigenschaften in PADS®
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Wenn ein Thermal- oder Antipad-Wert in PADS® auf einen bestimmten Pin oder eine bestimmte Komponente angewandt 

werden kann, wird diese Regel während der Umwandlung auf den Footprint gerichtet. Deshalb wirkt sich dies auf alle 

Komponenten des Designs aus, die diesen Footprint nutzen.

Konfigurieren von Design-Regeln für Wärmefallen für Vollkupferlagen in Altium Designer
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ÜBERSETZUNG DER BAUTEILBIBLIOTHEKEN

BAUTEILBIBLIOTHEK IMPORT-PROZESS

Die Umwandlung von PADS®-Bibliotheken geht folgendermaßen:

1.	 File » Import Wizard wählen

2.	 Im Begrüßungsbildschirm auf Next klicken und ‚PADS® ASCII Design and Library Files’ auswählen. Mit Next geht es weiter.

3.	 Erneut auf Next klicken, um den Design Import-Bildschirm zu überspringen.

4.	 Im Importing PADS® Libraries-Bildschirm auf Add klicken, um eine oder mehrere Bibliotheksdateien zu laden.

Schaltplansymbol-Bibliotheken

Wie schon im Abschnitt ASCII-Datei Erstellung beschrieben, erfordert das Umwandeln von Schaltplansymbol-Bibliotheken zwei 

Dateien – eine ‚*.c’ & ‘*.p‘-Datei – um die Schaltplansymbol-Bibliothek für Altium Designer korrekt anzulegen.

5.	 Im Fenster ‚Load PADS® Library Files’ die ‚*.c’ & ‘*.p‘-Datei der zu übersetzenden Bibliothek wählen und auf Open klicken.

Laden der PADS®-Bibliotheksdateien in den Altium Designer Import Wizard

6.	 Zwei weitere Male auf Next klicken, um den Übersetzungsprozess zu starten. Ist der Vorgang abgeschlossen, kann die 

konvertierte Bibliothek für Schaltpläne im Projects-Fenster geöffnet werden.

Das Projects-Fenster in Altium Designer
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PCB Footprint-Bibliotheken (Decals)

Der Import von PADS® Decals erfolgt nach derselben Methode – abgesehen von der Tatsache, dass die zu ladende Datei die 

Namenserweiterung ‚*.d‘ besitzt.

7.	 Die zu überstzende(n) Dateien(en) auswählen und auf Open klicken.

8.	 Zwei weitere Male auf Next klicken, um durch den Wizard zu gehen.

Laden von PADS® Decal-Bibliotheken

Für den Import einer Decal-Datei gibt es im Import Wizard die Layer-Mapping-Option, die dem PCB Design Layer Mapping 

ähnelt. Auch hier wird versucht, gleiche Lagen aufeinander abzubilden (z. B. Siebdruck auf Siebdruck). Zur Erinnerung: Es ist 

nicht notwendig, alle PADS®-Lagen auf eine Lage von Altium Designer abzubilden.

Konfigurieren der Lagenzuweisung im Import Wizard
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9.	 Ist die betreffende Lage zugeordnet, beginnt nach zweimaligem Anklicken von Next die Übersetzung. 

10.	Nach erfolgter Konvertierung lässt sich die PCB-Footprint-Bibliothek aus dem Projects-Fenster heraus öffnen.

Das Projects-Fenster in Altium Designer

Tipp: Symbol-Bibliotheken und PCB-Decal-Bibliotheken lassen sich mit demselben Importprozess konvertieren.

Übersicht über die importierten Bibliotheken im Import Wizard

SYMBOLBIBLIOTHEK AUFRÄUMEN

Schaltplansymbole werden normalerweise korrekt umgewandelt. Dies betrifft die Grafik, Pin-Namen und -Nummern, Parameter 

und Verknüpfung auf Decals/Footprints. Dennoch können geringfügige Editierungen an der Symbolbibliothek erforderlich sein. 

Dazu die folgenden Beispiele:

Anordnung von Text und Pin-Namen

Unterschiede in den standardmäßigen Fonts von PADS® können dazu führen, dass die Gesamtgröße und Positionierung von 

Pin-Namen und -Nummern nicht 100-prozentig übereinstimmt. Außerdem werden die Pin-Namen auf ihre Standard-Position 

und -Ausrichtung (direkt neben dem Pin) zurückgesetzt.
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Ein Symbol in PADS®

Das gleiche Symbol in Altium Designer. Die Namen der oberen und unteren Pins sind wieder auf 0° Rotation zurückgesetzt 

Die Pin-Namen lassen sich in Altium Designer mit der Einstellung ‚Customize Position’ im Pin Properties-Dialog anpassen.

Anpassung der Pin-Eigenschaften in Altium Designer
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Invertierte und negierte Pins

Wie im Abschnitt über das Bereinigen von Schaltplänen beschrieben, werden invertierte Signale in Altium Designer anders 

definiert als in PADS®. Für Pin- (Signal-)Namen gelten dieselben Einstellungen, sodass auch sie modifiziert werden sollten. Die 

folgenden Beispiele zeigen die Unterschiede zwischen PADS® und Altium Designer.

Pin-Beispiel in PADS® Der gleiche Pin in Altium Designer Der Pin-Name muss von R/\W in R/W\ geändert 
werden (Verschiebung des Backslash hinter das W).

FOOTPRINT-BIBLIOTHEK AUFRÄUMEN

PCB-Decals werden normalerweise korrekt übersetzt. Dies betrifft die Grafik, Pin-Nummern und Padstacks, Siebdruck, 

Kupferformen usw.. Trotzdem können in geringem Umfang Nacharbeiten an den Footprint-Bibliotheken notwendig sein. Auf 

die folgenden Bereiche ist zu achten:

Keepouts

Bei der Beschreibung der PCB-Bereinigung wurde im Abschnitt über Keepouts bereits darauf eingegangen, dass sich die 

Fähigkeiten von PADS® und Altium Designer erheblich unterscheiden. Im Zusammenhang mit der Footprint-Bibliothek 

aber verdient nur eine Situation gesonderte Beachtung: ein PADS®-Keepout kann nämlich so konfiguriert werden, dass nur 

bestimmte Objekttypen ferngehalten werden. Es ist zum Beispiel üblich, Via-spezifische Keepouts in Footprints zu verwenden 

(z. B. zwischen den Pins eines Kondensators).

Via-Keepouts in PADS® werden in Altium Designer zu Sperrflächen für alle elektrischen Objekte. Weil es in Altium Designer 

keine Entsprechung zu den rein auf Vias beschränkten Keepouts gibt, sollten Sperrflächen dieser Art ganz entfernt werden, 

sofern ihre genauen Auswirkungen unklar sind.

Ein weiteres gängiges Footprint-spezifisches Keepout sind Copper-Pour-Keepouts. Ein für solche Kupferflächen konfiguriertes 

Keepout wird in Altium Designer ebenfalls zu einer vollständigen Sperrfläche. Allerdings lassen sich zu einem Footprint in 

Altium Designer (mit Place » Polygon Pour Cutout) Sperrflächen für Polygone hinzufügen, um die Situation zu korrigieren. 

Nach dem Hinzufügen des Cutouts darf nicht vergessen werden, das ursprüngliche Keepout-Objekt zu entfernen.

Lötstopp- und Pastenmasken

Mit einer Default-Regel fügt Altium Designer automatisch Werte für die Öffnung von Lötstopp- und Pastenmasken hinzu. Sind 

diese in PADS® eigens definiert, werden die Padstack-Werte in Altium Designer entsprechend eingestellt. Sind keine Lötstopp- 

und/oder Pastenmasken definiert, werden die Default-Einstellungen von Altium Designer angewendet.

Zum Beispiel wird zum Padstack eine Pastenmaske mit 5 mil Übergröße hinzugefügt (5 mil mehr in jede Richtung, um den 24 

mil betragenden Abstand der Lötstoppmaske auf 34 mil zu vergrößern).
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Konfigurieren der Padstack-Eigenschaften in PADS®

Der Wert von 5 mil wird dann als ‚Paste Mask Expansion‘ in den Pad-Eigenschaften von Altium Designer eingetragen. Da in 

PADS® keine Lötstoppmasken-Lage zum Padstack hinzugefügt wurde, wird für die Öffnung der Default-Wert aus der Regel 

herangezogen.

Konfigurieren der Pad-Eigenschaften in Altium Designer

PADS® lässt bei den Masken unabhängige Oversize/Undersize-Werte für Länge und Breite zu. In diesem Beispiel wurde also 

die Pad-Breite von 24 mil auf 34 mil angehoben, während die Pad-Länge auf der Pastenmasken-Lage bei 74 mil belassen 

werden kann. Altium Designer wendet die Werte dagegen in allen Richtungen an (d. h. Pads werden insgesamt vergrößert oder 

verkleinert). Deshalb ist es wichtig nach Pads zu suchen, die unterschiedliche Oversize/Undersize-Werte für Länge und Breite 

aufweisen.

Tipp: Wenn in PADS® unterschiedliche Oversize/Undersize-Werte für Länge und Breite angegeben sind, wird bei der 

Umwandlung für Altium Designer der kleinere der beiden Werte verwendet.
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SCHALTPLÄNE UND PCB SYNCHRONISIEREN

PROJEKTMANAGEMENT

Obwohl Schaltplan- und PCB-Designs in ein und derselben Sitzung des Import Wizard konvertiert werden können, erfolgen 

die Umwandlungen als separate Prozesse. Bei der Umwandlung eines jeden Designs werden die resultierenden Dateien in 

separaten Projekten abgelegt. Im vorliegenden Beispiel wurden der Schaltplan ‚Preview‘ und das PCB-Design ‚Previewpour‘ 

gleichzeitig vom Import Wizard verarbeitet, jedoch entstanden dabei separate Projekte und Ordnerstrukturen.

Gleichzeitiges Bearbeiten von zwei importierten Projekten in Altium Designer

Soll das Projekt in vollem Umfang wiederhergestellt werden, ist ein gewisses Dateimanagement erforderlich. Generell ist es 

empfehlenswert, alle Projektdateien in einem Ordner abzulegen. Da es meist mehrere Schaltpläne, aber nur ein PCB-Dokument 

gibt, ist es am einfachsten, die ‚*.PcbDoc‘-Datei in den Projektordner zu holen, in dem sich die ‚*.SchDoc‘-Dateien befinden.

An diesem Punkt wird das importierte PCB-Projekt (in diesem Fall also ‚previewpour.PrjPcb’) nicht benötigt, sodass es geschlossen 

werden kann. Machen Sie einen Rechtsklick auf den Projektnamen im Fenster und klicken Sie anschließend auf Close Project. 

Von jetzt an ist ‚Preview.PrjPcb‘ das Arbeitsprojekt. Nun muss noch die ‚*.PcbDoc‘-Datei zum Projekt hinzugefügt werden. 

Wählen Sie Project » Add Existing to Project, fügen Sie die ‚*.PcbDoc’-Datei hinzu und speichern Sie das Projekt danach.

Weitere Informationen über Projekte finden Sie in der technischen Dokumentation unter Project Management. 

SYNCHRONISATION

Altium Designer benutzt für die Synchronisation der Schaltpläne mit dem PCB sogenannte „Unique IDs“. Das ist vergleichbar 

mit einer nur einmal existierenden Seriennummer für jedes Bauteil. Wenn ein Projekt von Grund auf neu in Altium Designer 

erstellt wird, vergibt das System automatisch für jedes platzierte Bauteil im Schaltplan-Editor eine „Unique ID“. 

Bei der Übergabe der Schaltpläne in den PCB-Editor werden diese eindeutigen Kennungen an die entsprechenden Footprints 

übergeben. Im unten gezeigten Beispiel hat das Bauteil mit der Referenzbezeichnung U3 sowohl im Schaltplan als auch PCB 

die Unique ID “QPWPFFFF”.

Hinweis: Die “Unique ID” in der Abbildung der Komponenteneigenschaften im PCB-Editor (“\UIRYJOSQ\AFOPTWNK\”) kommen 

wegen des hierarchischen Aufbaus des Designs zustande.
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Eigenschaften von Komponenten in Altium Designer

Eigenschaften von Komponenten in Altium Designer

Nach einer Übersetzung eines PCBs von PADS® sind die „Unique IDs“ den entsprechenden Footprints nicht zugeordnet. Dies 

beruht auf der Tatsache, dass die beiden Design-Teile durch unabhängige Prozesse übersetzt wurden. Glücklicherweise gibt 

es ein sehr einfaches Verfahren, um die „Unique IDs“ zwischen Schaltplan und PCB abzugleichen. Hier die einzelnen Schritte:

1.	 ‘.PcbDoc’ Datei öffnen und Project » Component Links wählen.
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Konfiguration der Komponenten-Links zwischen Schaltplan und PCB

Alle Komponenten in den beiden linken Teilen der Dialog-Box haben keine übereinstimmenden „Unique IDs“. Das Ziel 

ist es nun, die Komponenten auf den Schaltplänen mit den zugehörigen  Footprints im PCB mit identischen „Unique IDs“ 

auszustatten. Dies kann manuell geschehen, indem ein zusammengehörendes Paar angewählt wird und mit der Schaltfläche 

> in den „Matched Components“ Teil der Dialogbox verschoben wird.

Es gibt auch ein automatisiertes Verfahren, das auf einer beliebigen Kombination von Referenzbezeichnung, Kommentar und 

Footprint-Namen beruht. Da das Design ursprünglich in Mentor Graphics PADS® erstellt wurde, kann man davon ausgehen, 

dass die Kurzbezeichnungen der Komponenten zwischen Schaltplänen und dem PCB identisch sind.

2.	 Designator-Checkbox am unteren Rand der Dialog-Box einschalten und Comment und Footprint ausschalten.

3.	 Die Schaltfläche Add Pairs Matched By >> auswählen. Dies gruppiert mithilfe der Referenzbezeichnung automatisch die 

Komponenten der Schaltpläne mit den Footprints im PCB.

Mithilfe der Kurzbezeichnungen werden die Schaltpläne mit dem PCB synchronisiert
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4.	 Um die „Unique IDs“ zu synchronisieren, Perform Update auswählen.

5.	 OK drücken.

Bestätigung der Modifikationen

Nun stehen auch Funktionalitäten wie Cross-Probing und die Verwaltung von Änderungen (ECO) zur Verfügung.

Es ist zu erwähnen, dass es nicht zwingend eine eins-zu-eins Übereinstimmung der Kurzbezeichnungen geben muss. Im obigen 

Beispiel ist die Komponente X1, eine mechanische Komponente, zusätzlich auf der Leiterplatte platziert worden und hat keine 

Repräsentation auf einem Schaltplan. Das gleiche kann auch bei Befestigungsbohrungen vorkommen. Auch der umgekehrte 

Fall kann auftreten – eine Komponente kann im Schaltplan platziert werden, um in der Stückliste gelistet zu sein, aber keine 

physikalische Repräsentation auf der Leiterplatte haben. Dies könnte beispielsweise ein Kühlkörper sein.

In PADS® werden solche Situationen mithilfe der Eigenschaft ECO Registered gesteuert. Altium Designer hat verschiedene 

Optionen, um Komponententypen handzuhaben, die das Verhalten beim ECO beeinflussen. Die folgende Abbildung zeigt die 

verfügbaren Typen für Komponenten, die sowohl im Schaltplan als auch im PCB genutzt werden können.

Definition des korrekten Komponententyps für einen ECO in Altium Designer

Mehr Information über die unterschiedlichen Typen für Komponenten gibt es in dem Artikel Component, Model, and Library 

Concepts.

Einem Bauteil kann jederzeit ein anderer Komponententyp zugewiesen werden. Wird der Typ „Mechanical“ bei der Komponente 

X1 auf der Leiterplatte angewendet, dann ist die Komponente vom ECO-Prozess ausgeschlossen. Ansonsten würde das Bauteil 

beim ECO-Prozess entfernt werden, weil es keine Repräsentation im Schaltplan hat.
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Verwaltung von Änderungen (Engineering Change Orders)

Die Durchführung eines ECOs sollte alle verbleibenden Unstimmigkeiten zwischen den Schaltplänen und dem PCB aufdecken. 

Der ECO-Prozess wird unter Design » Import Changes from <project name> gestartet. Unter Umständen wird ein 

Info-Dialog (je nach Situation auch zwei) angezeigt, welcher dazu auffordert, die Netznamen manuell anzupassen.  Es wird 

empfohlen, den Info-Dialog mit No zu schließen, durch die Änderungsliste zu gehen und dann alle Netze umzubenennen sowie 

andere Unstimmigkeiten zu bereinigen.

Bestätigung der manuellen Abstimmung von Netznamen

Obwohl es manchmal nötig ist, einige Änderung vorzunehmen, ist die wichtigste Aufgabe das Umbenennen der vom System 

zugewiesenen Netznamen. Wie bereits im Abschnitt Schaltplan Import-Prozess beschrieben, werden in PADS® und Altium 

Designer systemgenerierte Netznamen unterschiedlich erstellt. Es ist empfehlenswert, dass der ECO-Prozess die PADS® 

Netznamen in Altium Designer Netznamen ändert, wie in folgender Abbildung gezeigt.

Systemgenerierte Zuweisung der Netznamen in Altium Designer

Eine generelle Steuerung des ECO-Prozess kann unter Project » Project Options definiert werden. Auf diese Weise 

synchronisiert und/oder entfernt Altium Designer eigenständig Netzklassen, Komponentenklassen und vieles mehr.

Synchronisation von Änderungen in Altium Designer
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Es liegt in der Entscheidung des Anwenders, Änderungen zu akzeptieren oder abzulehnen. Die kleine Checkbox in der ECO 

Dialog-Box erlaubt es dem Benutzer, eine bestimmte Änderung vorübergehend zu deaktivieren. Eine permanente Deaktivierung 

von Änderungen kann im ECO Generation Tab der Project » Project Options Dialog-Box eingestellt werden.

Eine wichtige Option, die eingestellt werden muss, ist Remove Net Classes. Altium Designer versucht die Netzklassen 

zu synchronisieren, die im Schaltplan bzw. im PCB erstellt wurden. Wenn während der Übersetzung der Design-Regeln 

irgendwelche Netzklassen erstellt wurden und/oder Netzklassen in PADS® Layout, aber nicht in PADS® Logic definiert wurden, 

versucht der ECO-Prozess standardmäßig, diese zu entfernen, damit das PCB exakt mit dem Schaltplan übereinstimmt.

Konfiguration von Projektoptionen für den ECO in Altium Designer

Mit dem Setzen der Option Remove Net Classes auf ‚Ignore Differences’ verhindert man das Entfernen von Netzklassen, die 

nur in der PCB-Datei existieren.

Es gibt noch eine ganze Reihe von Situationen, die Unterschiede während des ECO-Prozesses zwischen Schaltplänen und 

PCB verursachen können. Es würde den Rahmen dieses Leitfadens sprengen, alle möglichen Szenarien zu beschreiben. Der 

Anwender sollte aber in der Lage sein, die Quellen für Unterschiede auszumachen, indem er die Konzepte nutzt, die Altium 

hierfür zur Verfügung stellt. Weitere Information gibt es in der technischen Dokumentation unter Finding Differences and 

Synchronizing Designs.

Das Ziel sollte es sein, den ECO-Prozess so abzuschließen, dass entweder kein ECO notwendig ist oder keine Unterschiede, 

abhängig von den Optionen in den Projektoptionen, zwischen Schaltplänen und PCB gefunden werden.

“No Differences” Dialog-Box
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DIE NÄCHSTEN SCHRITTE IN ALTIUM DESIGNER
Nachdem alle Design-Daten erfolgreich von PADS® importiert sind, ist es jetzt an der Zeit, sich intensiver mit der vereinheitlichten 

Design-Umgebung von Altium Designer auseinanderzusetzen und die Feinheiten kennenzulernen. Im Folgenden sind einige 

Links zu unserer Dokumentation, Video-Tutorials und Trainings gelistet, die Ihnen helfen werden, Altium Designer optimal zu 

nutzen.

DOKUMENTATION

�� Getting Started with Altium Designer – Tutorial für die ersten Schritte zur Erstellung eines Schaltplans und PCBs.

�� The Altium Designer Environment – Überblick über die vereinheitlichte Design-Umgebung in Altium Designer.

�� Library and Component Management – Dokumentation zur Verwaltung von Komponenten und Bibliotheken.

Dies ist nur ein kleiner Auszug aus unserem riesigen Archiv an Dokumentation für Altium Designer. Mehr finden Sie unter www.

altium.com/documentation/.

VIDEO-BIBLIOTHEK

Unsere Video-Bibliothek enthält viele Tutorials, Erklärungen zu Funktionalitäten und vieles mehr. Hier können Sie sich mit dem 

Altium Designer vertraut machen. Die Videos finden Sie unter Altiumlive Video Library.

TRAINING

Bevorzugen Sie einen praxisnahen Lernansatz? Registrieren Sie sich für eines unserer Live-Events, darunter Webinare, 

Schulungen und Seminare. Eine Übersicht des Angebots finden Sie unter Altium Events page.

SIE BENÖTIGEN ZUSÄTZLICHE HILFE?

Unser Support-Team steht ihnen für alle Fragen zur Verfügung. Nehmen Sie direkt mit uns Kontakt auf über die Contact Us 

page.
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