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EIN﻿FÜHRUNG

Dieses Tutorial beginnt mit der Skizze eines Schaltkreises und erläutert Ihnen Schritt für Schritt den Prozess vom ursprünglichen 

Schaltkreis über die Darstellung als Schaltplan und die Umsetzung des Schaltkreises als Leiterplatte bis zum Erstellen der für die 

Leiterplattenherstellung erforderlichen Ausgaben.

Grundlage dieses Tutorials ist das Design eines astabilen Multivibrators. Für Anwender, die noch nicht mit der Altium-Software 

vertraut sind, kann die Lektüre des Artikels Exploring Altium Designer mit Erläuterungen zur Benutzeroberfläche, Informationen 

zur Verwendung von Fenstern und Richtlinien für die Verwaltung von Design-Dokumenten hilfreich sein.

DAS﻿ DESIGN

Bei dem Design, das als Leiterplatte (PCB) erfasst und realisiert wird, handelt es sich um einen einfachen astabilen Multivibrator. 

Der Schaltkreis ist nachfolgend dargestellt; es werden zwei Transistoren des Typs 2N3904 verwendet, die als selbstlaufender 

astabiler Multivibrator konfiguriert sind.

Skizze einer astabilen Multivibrator-Schaltung

Der erste im Tutorial erläuterte Schritt ist das Erfassen (Zeichnen) des Schaltplans. Zuvor muss jedoch ein Projekt angelegt 

werden.

EIN PCB-PROJEKT ERSTELLEN﻿

Das PCB-Projekt beinhaltet die Design-Dokumente (Dateien), die benötigt werden, um eine Leiterplatte zu spezifizieren und 

herzustellen. Weiterführende Informationen über das Verwalten und Erstellen von Projekten in Altium Designer finden Sie 

hier. 

1.	 Erstellen Sie ein neues PCB-Projekt mit File » New » Project » PCB Project.

Erstellen eines neuen PCB-Projektes

http://www.altium.com
http://www.altium.com/documentation/18.0/display/ADES/Exploring+Altium+Designer
http://www.altium.com/documentation/18.0/display/ADES/Project+Management+in+Altium+Designer
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3. Der Projektname wird im Project Panel angezeigt.

Das Project Panel

EINEN﻿ SCHALTPLAN ZUM PROJEKT HINZUFÜGEN

1. Klicken Sie mit der rechten Maustaste auf Multivibrator.PrjPcb und wählen Sie den Pfad Add New to Project » 
Schematic aus.

Erstellen eines neuen Schaltplans für den Schaltkreis

Schaltplan im Projects Panel

2. Wählen Sie den folgenden Pfad aus, um das Schaltplanblatt zu speichern File » Save As oder wählen Sie Save       .  

Geben Sie den Namen Multivibrator in das Feld File Name ein und klicken Sie auf Save. (Die Dateierweiterung 

*.SchDoc wird automatisch hinzugefügt).

2.  Um das neue Projekt zu speichern, wählen Sie File » Save Project As… . Wählen oder erstellen Sie das Projektverzeichnis 

und speichern Sie das Projekt unter dem Namen Multivibrator.

http://www.altium.com
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Wenn sich der leere Schaltplan öffnet, ändern sich die Haupt-Menüleiste 

und die entsprechenden Buttons für die Schaltplaneingabe und die 

Active Bar wird im Arbeitsbereich anzeigt. Die Active Bar wird in 

allen Dokument-Editoren in Altium Designer angezeigt und ermöglicht 

die Auswahl von PCB‑, Schaltplan‑, Draftsman‑ und Bibliotheksobjekte 

mit nur einem einzigen Mausklick. Sie können darüber hinaus viele 

Ansichten des Arbeitsbereiches, einschließlich Neupositionierung und 

Anpassung von Fenstern und Werkzeugleisten, individuell anpassen.

Schaltplan-Dokument Active Bar

Bei Active Bar-Symbolen mit einem Dreieck rechts unten können 

mit einem Klick auf die rechte Maustaste weitere Objekte für die 

Platzierung ausgewählt werden:

Bus Entry im Schaltplan-Dokument Active Bar

SCHALTPLAN-VOREINSTELLUNGEN FESTLEGEN﻿﻿

Richten Sie vor dem Entwerfen eines Schaltkreises mit den folgenden Schritten die richtigen Dokumentoptionen ein:

1. Wählen Sie für die Seitengröße die Option Letter – wie im folgenden Leitfaden beschrieben:

Einstellen der Seitengröße im Fenster Preferences

Wählen Sie folgende Option aus, damit das Dokument den gesamten Anzeigebereich ausfüllt View » Fit Document 

(Tastenkombination: V, D).

Speichern Sie den Schaltplan, indem Sie auf das Symbol        klicken oder den Pfad File » Save (Tastenkombination: F, S) 

auswählen.

http://www.altium.com
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BAUTEILE IM SCHALTPLAN PLATZIEREN﻿

Einstellen der Seitengröße im Fenster „Preferences“

Schauen Sie sich die oben abgebildete grobe Skizze des Schaltkreises an und platzieren Sie die 2N3904 -Transistoren Q1  
und Q2.

1. Öffnen Sie das Libraries Panel, indem Sie auf die Schaltfläche Panels rechts unten in der Software klicken und die Option 

Libraries auswählen. 

2. Suchen Sie den 2N3904 -Transistor im Fenster, indem Sie entweder durch die Bauteilliste scrollen oder die Schaltfläche 

„Search“ anklicken.

Sie können jeden Befehl ausführen, indem Sie das Tastaturkürzel für den entsprechenden Befehl drücken (den unterstrichenen 

Buchstaben im Menünamen). Für die Menüelemente gibt es ebenfalls Schnellzugriffstasten, die Sie zur Auswahl eines Befehls 

verwenden können.

Zur Auswahl des Befehls View » Fit Document müssen Sie zuerst die V-Taste drücken und anschließend die D-Taste.

Außerdem können viele Untermenüs, wie zum Beispiel das Menü „Select“ (im Menü „Edit“), direkt aufgerufen werden.  

Um beispielsweise den Befehl Edit » Select » Touching Line aufzurufen, müssen Sie nur die S-Taste drücken (direktes 

Aufrufen des Menüs „Select“) und anschließend die L-Taste drücken.

Öffnen des Libraries Panel

http://www.altium.com
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3. Klicken Sie auf den Eintrag 2N3904 und anschließend auf die Schalt-

fläche Place. Der Mauszeiger wird daraufhin zu einem Fadenkreuz.  

An Ihren Mauszeiger wird der Umriss des Transistors angehängt.

 Platzieren Sie den Transistor jedoch noch nicht!

4. Drücken Sie die “Tab” Taste, bevor Sie das Bauteil auf dem Schaltplan 

platzieren, um das Fenster „Eigenschaften“ zu öffnen und die Platzierung 

anzuhalten. Geben Sie im Abschnitt Properties des Dialogfeldes Q1 in 

das Feld Designator ein. 

5. Fahren Sie mit dem Platzieren fort, indem Sie auf den Pause-Button 

klicken, der in der Mitte des Schaltplans angezeigt wird. Befindet sich 

der Transistor in der gewünschten Position, klicken Sie auf die linke 

Maustaste oder drücken Sie die Enter-Taste auf der Tastatur, um den 

Transistor im Schaltplan zu platzieren.

6. Das System bleibt im Modus zum Platzieren von Bauteilen, und der 

Umriss des Bauteils wird weiter am Mauszeiger angezeigt. Platzieren Sie jetzt den zweiten Transistor. Da es sich um 

dasselbe Bauteil handelt wie das bereits platzierte Bauteil, erhöht die Software automatisch die Referenzbezeichnung.

7. In der oben gezeigten Schaltungsskizze ist erkennbar, dass Q2 das Spiegelbild von Q1 ist. Um den an den Cursor 

angehängten Transistor zu spiegeln, drücken Sie die X-Taste auf der Tastatur. Dadurch wird das Bauteil horizontal 

(entlang der X-Achse) gespiegelt.

8. Bewegen Sie den Mauszeiger, um das Bauteil rechts neben Q1 zu platzieren. Drücken Sie für eine genauere Platzierung 

des Bauteils die PageUp-Taste zweimal, um die Ansicht in zwei Stufen zu vergrößern. Sie sollten nun die Rasterlinien 

sehen können.

9. Hat das Bauteil die richtige Position, klicken Sie mit der linken Maustaste oder drücken Sie die Enter -Taste, um Q2 zu 

platzieren. Erneut wird eine Kopie des Transistors direkt am Mauszeiger angezeigt und auf dem Schaltplan platziert. Der 

nächste Transistor erscheint angehängt an den Mauszeiger und kann platziert werden.

10. Beenden Sie die Bauteilplatzierung, indem Sie mit der rechten Maustaste klicken oder die ESC-Taste drücken.  

Der Mauszeiger wird wieder zu dem normalen Pfeil.

Properties Panel während der Bauteilplatzierung

Gespiegelte Transistoren auf dem Schaltplanblatt platziert

http://www.altium.com
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 Verwenden Sie die folgenden Tasten, um das an den Mauszeiger angehängte Bauteil zu bearbeiten:

��  Y spiegelt das Bauteil vertikal

��  X spiegelt das Bauteil horizontal

��  Leertaste rotiert das Bauteil um 90° gegen den Uhrzeigersinn.

��  Shift+Leertaste rotiert das Bauteil um 90° im Uhrzeigersinn.

Widerstände platzieren

Platzieren Sie die vier Widerstände im Schaltplan.

1. Das Properties Panel wird in diesem Tutorial häufig verwendet. Docken Sie das Properties Panel deshalb links im 

Arbeitsbereich an. 

Für weitere Informationen zu Panels lesen Sie bitte den Artikel: Working with Panels in Altium Designer 

2. Stellen Sie sicher, dass im Libraries Panel die Bibliothek Miscellaneous Devices.IntLib aktiviert ist.

3. Aktivieren Sie den Filter, indem Sie res in das Filterfeld unter dem Bibliotheksnamen eingeben.

4. Klicken Sie zum Auswählen auf Res1 in der Bauteilliste und anschließend auf die Schaltfläche Place. Daraufhin wird das 

Widerstandssymbol an den Mauszeiger angehängt.

5. Platzieren Sie die vier Widerstände, ohne weitere Eigenschaften zu ändern.

6. Verwenden Sie den unten abgebildeten Grobentwurf als Referenz und wählen Sie jeden Widerstand im Schaltplan an, 

ändern Sie den entsprechenden Designator sowie die Value-Eigenschaftsfelder für jeden Widerstand, indem Sie den 

Widerstand anklicken und die Felder im Properties Panel aktualisieren. 

Skizze der astabilen Multivibratorschaltung

Einstellung von Value von R1 im Properties Panel

7. Das Eigenschaftsfeld Value, welches im obigen Schritt aktualisiert wurde, dient für die Schaltkreissimulation. Das 

Eigenschaftsfeld Name wird normalerweise verwendet, um das Bauteil auf dem Schaltplan und in nachgelagerten 

Berichten wie der Stückliste zu identifizieren. Durch die Eingabe von = Value in das Eigenschaftsfeld Name, wird der 

im Eigenschaftsfeld Value eingestellte Widerstand im Eigenschaftsfeld Name wiedergegeben. Wählen Sie alle vier 

Widerstände aus, indem Sie sie mit gedrückter Shift -Taste anklicken.

http://www.altium.com
http://www.altium.com/documentation/18.0/display/ADES/Working+with+Panels+in+Altium+Designer
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8. Das Properties Panel spiegelt nun die Parameter 

wider, die für alle vier Widerstände gelten. Ändern 

Sie das Eigenschaftsfeld Name auf = Value und das 

Eigenschaftsfeld Name gibt den Widerstandswert wieder, 

der im Feld Value für alle ausgewählten Widerstände – wie 

unten angegeben – eingestellt wurde.

Einstellung von Name auf den Value-Parameter von Widerständen  
im Properties Panel

9. Scrollen Sie dann nach unten zum Eigenschaftsfeld  Value, 

wobei alle vier Widerstände weiterhin ausgewählt sein 

müssen, und klicken Sie auf das Symbol        , um die 

Sichtbarkeit auszuschalten. Die vier Widerstände werden 

entsprechend geändert.

Sichtbarkeit des Widerstandswerts abgeschaltet

Kondensatoren platzieren

Platzieren Sie die beiden Steckverbinder.

1. Das Kondensator-Bauteil finden Sie ebenfalls in der Bibliothek Miscellaneous Devices.IntLib, die bereits im Libraries 
Panel ausgewählt sein sollte.

2. Geben Sie im Filterfeld des Bauteilescap ein (es befindet sich unter der ausgewählten Bibliothek im Libraries Panel). 

3. Klicken Sie in der Bauteilliste auf Cap, um es auszuwählen, und klicken Sie dann auf die Schaltfläche Place.  

Das Kondensator-Symbol wird an den Mauszeiger angehängt.

4. Drücken Sie die Taste Tab, um die Eigenschaften des Kondensators zu ändern. Setzen Sie den Designator im Dialogfeld 

„Component Properties“ auf C1, Name auf = Value. Setzen Sie nun den Wert des Eigenschaftsfeldes Value auf 20 nF 

und deaktivieren Sie die Sichtbarkeit für den Parameter Value.

5. Die untenstehende Abbildung dient als Referenz. Positionieren und platzieren Sie die beiden Steckverbindern auf die 

gleiche Weise, wie Sie die vorigen Bauteile platziert haben. Klicken Sie mit der rechten Maustaste oder drücken Sie 

die  ESC -Taste, um den Platzierungsmodus zu beenden.

Im Schaltplan platzierte Steckverbinder

http://www.altium.com
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Den Steckverbinder platzieren

Platzieren Sie die beiden Steckverbinder.

1. Wählen Sie die Option Miscellaneous Connectors.IntLib im Libraries Panel aus. Bei dem benötigten Steckverbinder 

handelt es sich um eine 2-polige-Buchse. Geben Sie *2 im Filterfeld des Libraries Panel ein. 

2-poliger Steckverbinder im Libraries Panel

2. Wählen Sie die Option Header 2 aus der Bauteilliste aus und klicken Sie auf die Schaltfläche Place. Drücken Sie die Tab-

Taste, um die Eigenschaften zu bearbeiten und setzen Sie den Wert für Designator auf Y1.

3. Drücken Sie X, bevor Sie den Steckverbinder platzieren, um diesen horizontal zu spiegeln, sodass er sich in der richtigen 

Ausrichtung befindet. Mit einem Klick platzieren Sie den Steckverbinder auf dem Schaltplan, wie in der Abbildung unten 

dargestellt.

4. Klicken Sie mit der rechten Maustaste oder drücken Sie die ESC -Taste, um den Bauteil-Platzierungsmodus zu beenden.

5. Speichern Sie Ihren Schaltplan mit  File » Save (Tastenkombination: F, S) oder klicken Sie auf das Symbol          .

2-poliger Steckverbinder im „Libraries“ Panel

http://www.altium.com
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VERBINDUNGEN IM SCHALTPLAN HERSTELLEN

 Verbinden Sie die Schaltungselemente nun gemäß der unten abgebildeten Skizze mit dem "Place Wire"-Befehl

Skizze der astabilen Multivibratorschaltung

1. Drücken Sie für eine optimale Ansicht des Schaltplans die Taste PageUp , um die Ansicht zu vergrößern bzw. die Taste  

PageDown , um die Ansicht zu verkleinern. Alternativ können Sie die Ansicht bei gedrückter Ctrl-Taste mit dem Mausrad 

vergrößern oder verkleinern oder die  Ctrl-Taste und die rechte Maustaste gedrückt halten und  und die Maus nach 
oben bzw. unten ziehen, um die Ansicht zu vergrößern bzw. zu verkleinern.

2. Wählen Sie den Befehl Place Wire in dein Active Bar (unten dargestellt) und verdrahten Sie den unteren Anschluss des 

Widerstandes R1 mit der Basis des Transistors Q1 wie folgt, indem Sie den Mauszeiger oberhalb des unteren Endes von  
R1 positionieren. Ein roter Verbindungsmarker (großes Kreuz) wird daraufhin an der Mauszeigerposition angezeigt. Dies 

signalisiert, dass sich der Mauszeiger über einem zulässigen elektrischen Verbindungspunkt des Bauteils befindet.

3. Klicken Sie mit der linken Maustaste oder drücken Sie die Enter-Taste, um den ersten Punkt der Verdrahtung zu 

setzen. Bewegen Sie den Mauszeiger und es erscheint eine Leitung vom Ankerpunkt bis zur aktuellen Mauszeigerposition. 

Die Standardeinstellung für den Eckmodus ist ein rechter Winkel. Die Tippbox unten erklärt, wie der Eckmodus geändert 

werden kann. Für diesen Schaltkreis ist der rechte Winkel allerdings die beste Wahl.

4. Positionieren Sie den Mauszeiger über der Basis von Q1, bis er sich in einen roten Verbindungsmarker verwandelt. 

Drücken Sie nun die Enter-Taste, um die Leitung mit der Basis von Q1 zu verbinden. Der Mauszeiger löst sich dann 

wieder von dieser Leitung. 

Hinweis: Der Mauszeiger bleibt ein Fadenkreuz, was darauf hindeutet, dass das System bereit ist, eine weitere Leitung zu 

platzieren. Klicken Sie zur vollständigen Beendigung des Platzierungsmodus sowie für die Rückkehr zum Pfeil-Mauszeiger mit 

der rechten Maustaste oder drücken Sie erneut die ESC-Taste. Verlassen Sie den Modus aber jetzt noch nicht.

5. Fügen Sie Verbindungen zu den verbleibenden Schaltkreisele-

menten hinzu, wie in der Abbildung unten dargestellt. Klicken 

Sie nach Abschließen des Platziervorgangs für alle Verbindun-

gen mit der rechten Maustaste oder drücken Sie die ESC-Tas-

te, um den Platzierungsmodus zu beenden. Der Mauszeiger ist 

dann wieder ein Pfeil.

Befehl „Place Wire“ in den Active Bar

Vollständige Verdrahtung des Schaltplans

http://www.altium.com
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NETZE UND NETZ-LABEL

Führen Sie die folgenden Schritte aus, um die Netz-Labels an den beiden Stromversorgungs-Netzen zu platzieren.

1. Wählen Sie die Option Place Net Label aus der Active Bar (unten markiert) aus. Ein Netz-Label wird daraufhin an den 

Mauszeiger angehängt.

Die Funktion Place Net Label in den Active Bar 

2. Um das Netz-Label vor seiner Platzierung bearbeiten zu können, drücken Sie die Tab-Taste, um die Platzierung zu 

unterbrechen, und wechseln Sie zum Properties Panel. Geben Sie den Wert 12 V in das Eigenschaftsfeld Net Name ein. 

Setzen Sie dann die Platzierung des Labels fort.

3. Platzieren Sie das Netz-Label so, dass seine untere linke Ecke die oberste Leitung im Schaltplan berührt, wie in der 

Abbildung unten gezeigt. Der Mauszeiger wird zu einem roten Kreuz, wenn das Netz-Label korrekt positioniert ist, um 

mit der Leitung verbunden zu werden. Ist die Farbe des Kreuzes hellgrau, bedeutet dies, dass keine zulässige Verbindung 

hergestellt wird. Unten sehen Sie das Netz-Label im freien Raum (linkes Bild) und an einer Leitung positioniert (rechtes 

Bild).

Falsche und richtige Platzierung von Netz-Labels

4. Nach der Platzierung des ersten Netz-Labels bleibt der Netz-Label-Platzierungsmodus aktiviert. Drücken Sie erneut die 

Tab-Taste, um das zweite Netz-Label zu bearbeiten, bevor es platziert wird. Geben Sie GND in das Eigenschaftsfeld Net 
Name ein.

Platzieren Sie das Netz-Label so, dass seine untere linke Ecke die unterste Leitung im dem Schaltplan berührt (wie in der 

Abbildung unten gezeigt). Klicken Sie mit der rechten Maustaste oder drücken Sie die ESC-Taste, um den Netz-Label-

Platzierungsmodus zu verlassen.

5. Speichern Sie Ihren Schaltkreis mit  File » Save (Tastenkombination: F, S). Speichern Sie auch das Projekt.

Gespeicherter, fertiggestellter Schaltplan

http://www.altium.com
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DEN SCHALTPLAN KOMPILIEREN UND VALIDIEREN

Beim Kompilieren eines Projektes wird es auf Einhaltung der Zeichnungsvorgaben und der elektrischen Regeln geprüft. Etwaige 

Warnungen und Fehler erscheinen im Messages Panel. Zugleich erscheinen detaillierte Informationen im Panel. Die Regeln für 

dieses Tutorial wurden vorab konfiguriert, sodass das Design für die Validierung bereit ist. 

1. Kompilieren Sie das Projekt mit  Project » Compile PCB Project Multivibrator.PrjPcb . Wenn Sie die Kompilierung 

bereits durchgeführt haben, wählen Sie Project » Recompile PCB Project Multivibrator.PrjPcb.

Ist das Projekt kompiliert, werden etwaige Warnungen und Fehler im Messanges Panel angezeigt. Das Fenster erscheint 

automatisch, sobald Fehler erkannt werden.

Ein PCB-Projekt kompilieren 

2. Wählen Sie View » Fit All Objects (Tastenkombination: V, F), um den gesamten Schaltplan anzuzeigen, und speichern Sie 

anschließend den Schaltplan und das Projekt.

Der Schaltplan ist damit fertig. In der nächsten Phase des Tutorials geht es darum, das Design als PCB zu realisieren. 

Weiterführende Informationen über das Schaltplan-Design finden Sie hier. 

Weitere Informationen zum Thema Design-Kompilierung und ‑Verifikation finden Sie hier.

EIN PCB ZUM PROJEKT HINZUFÜGEN

1. Wählen Sie den Pfad File » New » PCB.

Erstellen einer neuen PCB-Designdatei für das Projekt Eine neue PCB-Designdatei im „Projects“ Panel

http://www.altium.com
http://www.altium.com/documentation/18.0/display/ADES/((More+about+Schematics))_AD
http://www.altium.com/documentation/18.0/display/ADES/((Compiling+and+Verifying+the+Design))_AD
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2. Um die neue PCB-Datei zu speichern, wählen Sie File » Save As oder wählen Sie das Symbol           . Geben Sie den 

Namen Multivibrator in das Feld File Name  ein und klicken Sie auf Save.

3. Wenn sich die PCB-Designdatei öffnet, ändern sich die Haupt-

Menleiste und die zugehörigen Schaltflächen für die Bearbeitung 

des PCBs, und die Active Bar  wird im Arbeitsbereich angezeigt. PCB-Design-Datei Active Bar

ÜBERTRAGUNG DES SCHALTPLANS ZUM PCB

1. Starten Sie die Übertragung des Schaltplan-Designs zum PCB, indem Sie im PCB-Editor die Option  Design » Import 
Changes from Multivibrator.PRjPcb auswählen.

ECO-Dialog

2. Die Footprints der einzelnen Bauteile werden rechts von der PCB-Kontur angeordnet.

Außerhalb der PCB-Kontur platzierte Bauteile

BAUTEILE AUF DEM PCB PLATZIEREN

In diesem Abschnitt werden die Bauteile auf dem PCB platziert. Die Verbindungsleitungen werden automatisch neu optimiert, 

sobald Sie ein Bauteil bewegen. Auf diese Weise dienen die Verbindungsleitungen bei der Platzierung als Hinweis für die 

optimale Position und Ausrichtung des Bauteils.

1. Richten Sie die Leiterplatte im Editor aus, indem Sie die Maus bewegen, während Sie gleichzeitig die Ctrl-Taste und die 

rechte Maustaste gedrückt halten. Wenn die Maus über ein Rad verfügt, dann halten Sie dieses gedrückt, während Sie die 

Maus bewegen, um die Ansicht zu vergrößern bzw. zu verkleinern.

http://www.altium.com
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2. Bewegen Sie die Maus, während Sie die rechte Maustaste gedrückt 

halten, um die Anzeige zu verschieben. Das Zoomen erfolgt bezogen 

auf die aktuelle Mauszeigerposition; positionieren Sie deshalb vor 

dem Zoomen den Mauszeiger entsprechend.

Im Artikel Getting to know your Editor, finden Sie weitere Informationen 

über das Zoomen und Verschieben. 

3. Die Bauteile im Tutorial werden gemäß der Abbildung unten platziert. 

Um die Bauteile zu platzieren, richten Sie den Mauszeiger auf die 

Mitte des Bauteils aus und drücken und halten Sie dann die linke 

Maustaste. Der Mauszeiger wird daraufhin zu einem Fadenkreuz 

und springt zum Referenzpunkt des Bauteils. Bewegen Sie die Maus 

bei gedrückter Maustaste, um das Bauteil zu verschieben.

Platzierte Bauteile im Leiterplatten-Layout

DESIGN-REGELN DEFINIEREN UND VERWALTEN

Design-Regeln werden im Dialogfeld PCB Rules and Constraints Editor festgelegt und verwaltet. Das Dialogfeld hat zwei Teilbereiche:

�� Die Baumstruktur links enthält die verschiedenen Designregel-Kategorien. Erweitern Sie eine Kategorie, um die verfügbaren 

Regeltypen anzuzeigen. Erweitern Sie einen Regeltyp, um alle aktuell definierten Regeln dieses Typs anzuzeigen.

�� Auf der rechten Seite des Dialogfeldes werden die Informationen dargestellt, die sich auf die aktuelle Auswahl in der Struktur 

beziehen. Dabei kann es sich entweder um eine Übersicht der definierten Regeln des gewählten Typs, bzw. der ausgewählten 

Kategorie oder alle für das gesamte System definierten Regeln oder – wenn aktuell eine Regel ausgewählt ist – um die 

Restriktionen für diese Regel handeln.

PCB Rules and Constraints Editor

http://www.altium.com
http://techdocs.altium.com/display/ADRR/Getting+to+know+your+Editor


www.altium.com/de

PCB-DESIGN MIT ALTIUM DESIGNER - ERSTE SCHRITTE

16

Manuelles Erstellen einer neuen Design-Regel

1. Öffnen Sie den PCB Rules and Constraints Editor, indem Sie Design » Rules aus der Werkzeugleiste auswählen.

2. Navigieren Sie zu Routing und wählen Sie den Regeltyp Width aus.    

3. Klicken Sie entweder auf die Schaltfläche New Rule unterhalb der Auflistung der Regeln oder machen Sie einen 

Rechtsklick und wählen  New Rule aus dem Kontextmenü aus.

Eine neue PCB-Designregel erstellen

Hinweis: Behalten Sie im nächsten Abschnitt den Überblick über den Regelnamen. Wird eine neue Regel hinzugefügt, wird 

jedoch zunächst ein Standardname vergeben, der auf dem spezifischen Regeltyp basiert. Ist bereits eine Regel mit diesem 

Namen vorhanden, wird einfach die Ziffer erhöht (d. h. Width_1, Width_2 und so weiter). 

Eine Design-Regel ändern

1. Klicken Sie auf den neuen Eintrag für die Regel in der Ordnerstruktur auf der linken Seite oder doppelklicken Sie auf 

den Eintrag in der Übersichtsliste.

Legen Sie die neue Regel fest, indem Sie die folgenden Werte eingeben:

2. Geben Sie im Feld  Name  Width_12 V ein.

3. Legen Sie den Anwendungsbereich der Regel fest, indem Sie im ersten Drop-down-Menü Net  auswählen und im zweiten 

Drop-down-Menü 12 V.

4. Legen Sie die Restriktionen für die Regel wie folgt fest: Preferred Width = 0.50 mm, Min Width = 0.50 mm und Max 
Width = 0.50 mm.

5. Klicken Sie auf OK.

http://www.altium.com
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Detaillierte Design-Regelbearbeitung

Den Design Rule Wizard verwenden

Design-Regeln können auch mit dem  Design Rule Wizard erstellt werden. Wenn Sie auf Finish klicken, bevor Sie den Assistenten 

schließen, wird die neue Regel mit den im System hinterlegten Standardwerte für den ausgewählten Regeltyp erstellt.

1. Rufen Sie den  Design Rule Wizard im PCB-Editor auf, indem Sie im Hauptmenü auf  Design » Rule Wizard klicken oder 

auf die Schaltfläche Rule Wizard im Dialogfeld PCB Rules and Constraints Editor klicken.

2. Wählen Sie die Option Rule Type aus.

3. Geben Sie Width_12 V in das Feld Name und 12 V Net Route Width  in das Feld  Description ein.

4. Wählen Sie Routing » Width Constraint.

5. Klicken Sie auf Next.

Auswahl des Regeltyps

http://www.altium.com
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6. Wählen Sie für die Option Rule Scope  1 Net.

7. Klicken Sie jetzt auf Next.

Auswahl des Regel-Anwendungsbereichs

8. Legen Sie den Wert für Condition Value über die Drop-down-Liste auf 12 V fest und klicken Sie anschließend auf Next.

Hinweis: Das Erstellen einer benutzerdefinierten Abfrage ist ein leistungsfähiges Werkzeug für den Designprozess. Besuchen 

Sie die Webseite Query Language Reference Page, um weitere Informationen über das Erstellen von benutzerdefinierten 

Abfragen zu erhalten.

Bearbeitung des Regel-Anwendungsbereich

http://www.altium.com
http://www.altium.com/documentation/display/ADES/((Query+Language+Reference))_AD
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9. Setzen Sie die Priorität der Regel auf 2, indem Sie  zuerst auf Width_12V und anschließend auf Decrease Priority 

klicken.

Priorität von Regeln 

10. Klicken Sie jetzt auf Next.

11. Stellen Sie sicher, dass das Dialogfeld  Launch main design rules  aktiviert ist und klicken Sie anschließend auf Finish.

Fertigstellung von Regeln

http://www.altium.com
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12. Legen Sie die Restriktionen für die Regel wie folgt fest: Preferred Width = 0.50 mm, Min Width = 0.50 mm und Max 
-Width  = 0.50 mm.

13. Klicken Sie auf OK.

Das Dialogfenster Design Rule Checker

DIE DESIGN-REGELPRÜFUNG KONFIGURIEREN

1. Öffnen Sie das Dialogfeld Design Rule Checker, indem Sie die Option Tools » Design Rule Check auswählen.

2. Wählen Sie jetzt Rules To Check » Routing aus.

3. Machen Sie einen Rechtsklick in der Ansicht  Rules  und wählen Sie die Option  Online DRC – All On aus.

4. Nach einem weiteren Rechtklick in der Ansicht Rules wählen Sie die Option  Batch DRC – All On aus.

Der PCB Rules and Constraints Editor

http://www.altium.com
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INTERAKTIVES ROUTEN DER LEITERPLATTE

1. Vergewissern Sie sich, dass das Raster für das Routing geeignet ist. Um das Raster zu ändern, drücken Sie die 

Tastenkombination Ctrl+G, um den Cartesian Grid Editor zu öffnen. Geben Sie anschließend den Wert 0.125 mm in das 

Feld Step X ein und klicken Sie auf OK, um das Dialogfeld zu schließen.

2. Prüfen Sie, welche Lagen derzeit sichtbar sind, indem Sie die Registerkarte  Layer Tabs  im unteren Teil des Arbeitsbereiches 

anklicken. Falls der Bottom Layer nicht sichtbar ist, drücken Sie die Taste L, um das Dialogfeld Layers and Colors zu 

öffnen, und aktivieren Sie den Bottom Layer, indem Sie auf das Symbol         neben dem Namen der Lage klicken.

Das Layers and Colors-Panel

3. Klicken Sie auf die Registerkarte Bottom Layer im unteren Teil des Arbeitsbereiches, um diese Lage für das Routing zu 

aktivieren.

Interaktive Routing in der Active Bar

Registerkarte Bottom Layer

4. Wählen Sie Place » Interactive Routing aus dem Menü (Tastenkombination: P, T) oder klicken Sie auf die Schaltfläche 

Interactive Routing in der Active Bar, wie unten abgebildet. Der Mauszeiger wird zu einem Fadenkreuz, um zu 

signalisieren, dass Sie sich im interaktiven Routing-Modus befinden.

http://www.altium.com
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5. Platzieren Sie den Mauszeiger auf dem unteren Pad des Steckverbinders Y1. Wenn Sie ihn in die Nähe des Pads bewegen, 

wird er automatisch in der Mitte des Pads einrasten. Hierfür ist die Funktion Snap To Object Hotspot verantwortlich, 

die den Mauszeiger in die Mitte des nächstgelegenen elektrischen Objektes zieht (konfigurieren Sie Snap to Object im 

Properties Panel). Manchmal zieht die Funktion Snap To Object Hotspot den Mauszeiger auch dann, wenn dies nicht 

gewünscht wird. Drücken Sie in diesem Fall die Taste Ctrl, um die Funktion vorübergehend zu deaktivieren. 

Klicken Sie auf die linke Maustaste oder drücken Sie die Enter-Taste, um den ersten Punkt der Leiterbahn zu 

verankern.   

Das Routing von Widerständen

Bewegen Sie den Mauszeiger in Richtung des unteren Pads des Widerstands R1 und klicken Sie darauf, um ein vertikales 

Segment platzieren zu können. Beachten Sie, wie die Segmente unterschiedlich angezeigt werden (wie im Bild unten 

gezeigt).

Während des Routings werden die Segmente wie folgt angezeigt:

��  Durchgezogen – Das Segment wurde platziert.

��  Schraffiert – Bei schraffierten Segmenten handelt es sich um vorgeschlagene, jedoch nicht abgeschlossene Segmente. 

Diese werden mit einem Klick auf die linke Maustaste platziert.

��  Leer – Dies wird auch als Vorschau-Segment bezeichnet. Es zeigt an, wo das letzte vorgeschlagene Segment enden sollte.

Anzeige von Leiterbahnsegmenten

6. 

7. Führen Sie das Routing manuell durch, indem Sie auf die linke Maustaste klicken, um die Leiterbahnsegmente zu 

platzieren. Für die Verbindung, für die Sie das Routing aktuell durchführen, können Sie mit der Backspace-Taste das 

zuletzt platzierte Segment herausschneiden. Bewegen Sie Ihren Mauszeiger entlang des Pfads zurück; sobald Sie über ein 

bestehendes nicht zugeordnetes Segment kommen, löst sich das nicht zugeordnete Routing bis zu dieser Position auf.

http://www.altium.com
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8. Anstatt ein Routing bis zum Ziel-Pfad durchzuführen, können Sie auch die Tastenkombination Ctrl + Linksklick drücken, 

um die Funktion Auto-Complete zu nutzen und das Routing für die gesamte Verbindung durchzuführen.

9. Setzen Sie das Routing aller Verbindungen auf der Leiterplatte, wie unten dargestellt, fort.

Geroutete einlagige Leiterplatte

LEITERBAHNEN ÄNDERN UND EIN ERNEUTES ROUTING DURCHFÜHREN

Beim Routing können sowohl die oberen als auch die unteren Lagen verwendet werden, weil das PCB ursprünglich als 

doppelseitige Leiterplatte definiert war.

1. Löschen Sie zuerst das bisher erstellte Routing, indem Sie den folgenden Pfad im Menü auswählen:  

Route » Un-Route » All .

2. Führen Sie nun wie zuvor ein interaktives Routing durch. Um zwischen den einzelnen Routing-Lagen zu wechseln, drücken 

Sie die *-Taste auf der Zehnertastatur, um zwischen den Lagen zu wechseln, während die Leiterbahnen platziert werden. 

Sie können auch die Tastenkombination Ctrl+Shift+Rollen-Taste/Mausrad nutzen, um während des Routings zwischen 

den verfügbaren Signallagen zu wechseln.

Der PCB-Editor fügt bei Bedarf automatisch eine Durchkontaktierung ein (in Übereinstimmung mit der Design-Regel  

Routing Via), wenn auf eine andere Lage gewechselt wird.

3. Ändern Sie als nächstes eine vorhandene Leiterbahn. Hierfür gibt es zwei Methoden: erneutes Routing oder Neuanordnung. 

Bei einem erneuten Routing müssen Sie das Routing einer Verbindung nicht rückgängig machen, um den Pfad neu zu 

definieren. Beginnen Sie einfach mit dem interaktiven Routing und führen Sie ein erneutes Routing durch; die Funktion 

Loop Removal entfernt automatisch alle redundanten Leiterbahnsegmente einschließlich der Durchkontaktierungen.  

Im PCB-Editor ist ebenfalls ein Netzanalysewerkzeug integriert, das den Routing-Pfad mit fortschreitender Arbeit automatisch 

analysiert und redundante Segmente entfernt. Das Routing kann an jedem Punkt des neuen Routing-Pfads beginnen und 

enden, wobei falls nötig zwischen den Lagen gewechselt wird.

4. Um eine vorhandene Leiterbahn anders anzuordnen, ziehen Sie das 

Segment, indem Sie zunächst für die Auswahl des Segments einmal 

klicken. Positionieren Sie dann die Maus auf dem Segment, um den 

Mauszeiger mit vier Pfeilen anzuzeigen. Anschließend klicken und 

halten, um das Segment zu verschieben.

Vorhandene Leiterbahn verschieben (Vierfach-Pfeil)

http://www.altium.com
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5. Bitte beachten Sie, dass sich der Mauszeiger ändert, wenn Sie diesen auf der mittleren Ecke der Leiterbahn positionieren 

– dies ist ein anderer Modus, der verwendet wird, um ein einzelnes Segment in drei Segmente zu unterteilen.

Bestehende Leiterbahn segmentieren

Segment mit Leiterbahn-Mauszeiger

AUTOMATISCHES ROUTING DER LEITERPLATTE

Um sich von der Einfachheit des Auto-Routings überzeugen zu können, führen Sie die folgenden Schritte aus:

1. Machen Sie das für die Leiterplatte bestehende Routing rückgängig, indem Sie den folgenden Pfad im Menü auswählen  

Route » Un-Route » All  (Tastenkombination: U, U, A).

Das Routing einer Leiterplatte rückgängig machen

2. Klicken Sie auf das Symbol AutorouteBoard in der Active Bar, wie unten abgebildet. Das Dialogfeld Situs Routing 
Strategies lässt sich in zwei Bereiche unterteilen: Der obere Bereich des Dialogs zeigt den Routing Setup Report  an 

(denken Sie immer an eine Überprüfung auf Warnungen/Fehler, die in roter Schrift angezeigt werden) und im unteren 

Teil des Dialogfeldes erscheinen die verfügbaren Routing Strategies (die ausgewählte Strategie ist markiert). Bei dieser 

Leiterplatte sollte standardmäßig die folgende Strategie angezeigt werden: Default Multi Layer Board.

Symbol Auto-Route Board in der Active Bar

http://www.altium.com


www.altium.com/de

PCB-DESIGN MIT ALTIUM DESIGNER - ERSTE SCHRITTE

25

3. Klicken Sie auf die Option Route All im Dialogfeld Situs Routing Strategies an. Das Fenster Messages zeigt den Auto-

Routing-Prozess an.

Mit dem Autorouter geroutetes PCB

4. Speichern Sie die automatisch geroutete Leiterplatte nicht. Das Tutorial fährt mit dem manuellen Routing fort. Drücken 

Sie die Tastenkombination Ctrl-Z doppelt und verfolgen Sie, wie die Befehle Auto-Routing und Un-Route All rückgängig 

gemacht werden können.

Der Autorouter führt das Routing auf beiden Lagen durch, sowohl den oberen als auch den unteren. Die Leiterbahnen auf 

der oberen Lage werden rot dargestellt, die Leiterbahnen auf der unteren Lage dagegen blau. Die Lagen, die vom Autorouter 

verwendet werden, sind in der Design-Regel Routing Layers festgelegt, die standardmäßig für die oberen und unteren Lagen 

gelten. Bitte beachten Sie auch, dass die zwei Leiterbahnen, die vom Steckverbinder wegführen, breiter sind, wie in der zweiten 

Design-Regel Width, die Sie erstellt haben, angegeben.

VERIFIKATION VON PCB-DESIGNREGELN

1. Überprüfen Sie das PCB-Design, indem Sie den Pfad Tools » Design Rule Check… auswählen. Wurden keine Fehler 

gefunden, werden im Fenster Messages keine Meldungen angezeigt und das Fenster wird geschlossen. Der Bericht 

Design Rule Verification Report  wird erstellt und es wird eine Registerkarte im Arbeitsbereich angezeigt.

Design-Regelprüfung

http://www.altium.com
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2. Die Design-Regeln für das GND-Netz sind so festgelegt, dass Sie nicht über bzw. unter 0.50 mm liegen sollten.  

Erzeugen Sie einen absichtlichen DRC-Fehler, wie unten dargestellt, indem Sie ein Leiterbahnsegment im GND-Netz 

anklicken. Wechseln Sie dann zum Properties Panel und ändern Sie die Eigenschaft  Width auf 0.4 mm.

Ändern Sie den Wert für Width im Properties Panel.

3. Führen Sie den Design Rule Check erneut durch.

4. Die Regelprüfung sollte nun im Messages Panel einen Fehler anzeigen. Schließen Sie das Panel und sehen Sie sich 

den Design Rule Verification Report an. Der obere Teil des Berichtes enthält eine Zusammenfassung jeglicher 

Regelverletzungen. Die spezifischen DRC violations werden als Hyperlink-Text unterhalb der Zusammenfassung angezeigt. 

Durch Anklicken des Links wird der betreffende Bereich im Fenster des PCB-Editors angezeigt. Klicken Sie auf den Link, 

der sich am unteren Ende des Berichtes befindet, ähnlich wie unten abgebildet:

Anklickbare Fehlermeldungen

5. Der Fehler wird in einer vergrößerten Ansicht – ähnlich wie in der unteren Abbildung – markiert. Korrigieren Sie die 

Breite der Leiterbahn Width im Fenster Properties oder durch Eingabe der Tastenkombination Ctrl-Z , um Ihre 

Breitenänderung rückgängig zu machen. Speichern Sie die Datei und stellen Sie sicher, dass diese keine DRC-Fehler 

enthält, indem Sie sie erneut überprüfen.

Leiterbahn mit markierten Fehlern

http://www.altium.com
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DAS PCB IN 3D ANZEIGEN

1. Wechseln Sie in die 3D-Ansicht, indem Sie den Pfad View » 3D Layout Mode auswählen (Tastenkombination: 3) oder 

wählen Sie eine 3D-Ansichtskonfiguration aus der Liste in der PCB-Standard-Werkzeugleiste kann durch Rechtsklick in der 

Menüleite aktiviert werden. Die Leiterplatte wird als dreidimensionales Objekt angezeigt.

2. Zoomen Sie, indem Sie bei gedrückter Ctrl ‑ und Maustaste die Maus ziehen oder Ctrl + Mausrad rollen bzw. die 

Tasten PageUp/PageDown drücken.

3. Verschieben Sie die Ansicht seitlich, indem Sie die Maus nach rechts ziehen oder die Windows-Standardsteuerung über 

das Mausrad verwenden.

4. Rotieren Sie die Leiterplatte, indem Sie die Taste Shift drücken und die Maus nach rechts ziehen. Bitte beachten Sie, 

dass an der aktuellen Mauszeigerposition eine 3D-Kugel angezeigt wird, wie in der unteren Abbildung dargestellt. Die 

Drehbewegung erfolgt in der Mitte der Kugel (Positionieren Sie den Mauszeiger, bevor Sie die  Shift-Taste drücken, um die 

Kugel zu positionieren.), indem Sie die folgenden Steuerelemente verwenden. Bewegen Sie die Maus, um die einzelnen 

Elemente zu markieren und auszuwählen: 

5. Ziehen Sie die Kugel nach rechts, wenn der Mittelpunkt markiert ist – rotieren Sie in jede beliebige Richtung. 

6. Ziehen Sie die Kugel nach rechts, wenn der horizontale Pfeil markiert ist – rotieren Sie die Ansicht um die Y-Achse. 

7. Ziehen Sie die Kugel nach rechts, wenn der vertikale Pfeil markiert ist – rotieren Sie die Ansicht um die X-Achse. 

8. Ziehen Sie die Kugel nach rechts, wenn das Kreissegment markiert ist – rotieren Sie die Ansicht um die Z-Achse.

3D-Navigation des Leiterplatten-Layouts

http://www.altium.com
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AUSGABEDATEIEN FÜR DIE HERSTELLUNG GENERIEREN

1. Generieren Sie Fabrication Output-Dateien, indem Sie den Pfad File » Fabrication Outputs » Gerber X2 Files auswählen.

Gerber X2-Dateien generieren

2. Wählen Sie die Option Used On aus dem Drop-down-Menü Plot Layers.

Plot Layers

3. Wählen Sie die Option Used On aus dem Drop-down-Menü Plot Drills.

Plot Drills

4. Klicken Sie auf OK.

http://www.altium.com
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ÜBER ALTIUM

Altium LLC (ASX: ALU) ist ein multinationales Softwareunternehmen mit Sitz in San Diego (Kalifornien/USA), das sich auf Elektronik-Designsysteme für 
das 3D-Leiterplattendesign und die Embedded-Systems-Entwicklung spezialisiert hat. Altium-Produkte findet man überall – von den weltweit führenden 
Elektronik-Designteams bis zu den an der Basis arbeitenden Elektronikdesignern.

Mit seinem einzigartigen Technologie-Portfolio hilft Altium Unternehmen und Design-Communitys, Innovationen hervorzubringen, zusammenzuarbeiten und 
vernetzte Produkte zu schaffen, ohne dabei das vorgegebene Zeit- und Finanzbudget zu überschreiten. Angebotene Produkte sind ACTIVEBOM®, ActiveRoute®, 
Altium Designer®, Altium Vault®, Altium NEXUS™, Autotrax®, Camtastic®, Ciiva™, CIIVA SMARTPARTS®, CircuitMaker®, CircuitStudio®, Codemaker™, Common 
Parts Library™, Draftsman®, DXP™, Easytrax®, EE Concierge™, NanoBoard®, NATIVE 3D™, OCTOMYZE®, Octopart®, P-CAD®, PCBWORKS®, PDN Analyzer™, 
Protel®, Situs®, SmartParts™ und die TASKING®-Palette eingebetteter Software-Compiler und Upverter™.

Altium wurde 1985 gegründet und verfügt über weltweite Niederlassungen. Das Unternehmen ist in den USA in San Diego, Boston und New York City 
vertreten, in Europa in Karlsruhe, Amersfoort, Kiew, München, Markelo und Zug und in der asiatisch-pazifischen Region in Shanghai, Tokio und Sydney.  
Für weitere Informationen, besuchen Siewww.altium.com/de. Sie können Altium außerdem auf Facebook, Twitter,  LinkedIn und YouTube folgen.
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ZUSAMMENFASSUNG

Sie haben das Ende des Tutorials erreicht! Vielen Dank für Ihre Aufmerksamkeit. Das Tutorial hat Ihnen einen schnellen 

Überblick über den Design-Prozess mit Altium Designer verschafft. Schauen Sie sich auch gern unsere anderen Leitfäden der 

Reihe Erste Schritte an, um mehr über leistungsfähige Funktionen wie Draftsman® und ActiveRoute®zu erfahren.

Besuchen Sie auch unsere Website Altium.com/documentation, um weitere nützliche Dokumente zu entdecken. Außerdem 

empfehlen wir die Lektüre unseres Artikels Exploring Altium Designer mit Details zur Benutzeroberfläche, Informationen zur 

Verwendung von Panels sowie Richtlinien für die Verwaltung von Design-Dokumenten. Wenn Sie an einer intensiven Schulung 

interessiert sind, besuchen Sie bitte unsere Events-Webseite.

Die Gerber X2-Datei wird sofort in das Betrachtungs-Tool CAMtastic von Altium Designer geladen. Alternativ können 

auch Output Job Files für die Erstellung der Ausgabedaten verwendet werden. Bei diesem bestimmten Dokument handelt 

es sich um eine einheitliche Umgebung zum Festlegen aller Einstellungen für jegliche Arten von Ausgabetypen , einschließlich 

Gerber-Files, NC-Bohrdateien, Montagezeichnungen, Bestückungspläne und viele weitere Arten. Die Datei kann auch für 

unabhängige oder kombinierte Projekt-Ausgabetypen zum Erstellen von Design-Varianten verwendet werden.

Ansicht einer Gerber X2-Datei in CAMtastic

http://www.altium.com
http://altium.com/documentation
http://www.altium.com/documentation/18.0/display/ADES/Exploring+Altium+Designer
http://www.altium.com/events
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